summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2018-07-08 15:35:03 +0200
committerJonas Stein <jstein@gentoo.org>2018-07-08 15:35:03 +0200
commit2a5b475b452b770d76e8561cf9a600088849d69a (patch)
tree2d76eb4635c80247003b7051e51fceac47134a5b
parentmedia-libs/vulkan-layers: remove unused patch (diff)
downloadgentoo-2a5b475b452b770d76e8561cf9a600088849d69a.tar.gz
gentoo-2a5b475b452b770d76e8561cf9a600088849d69a.tar.bz2
gentoo-2a5b475b452b770d76e8561cf9a600088849d69a.zip
app-office/texstudio: bump to 2.12.10
Version bump to 2.12.10 Package-Manager: Portage-2.3.41, Repoman-2.3.9
-rw-r--r--app-office/texstudio/Manifest1
-rw-r--r--app-office/texstudio/texstudio-2.12.10.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/app-office/texstudio/Manifest b/app-office/texstudio/Manifest
index 9b59224be56f..de586539406d 100644
--- a/app-office/texstudio/Manifest
+++ b/app-office/texstudio/Manifest
@@ -1,4 +1,5 @@
DIST texstudio-2.11.2.tar.gz 24143941 BLAKE2B 2c17b70cd497338ee9c7cd7fda0bdcb8775c3b487ae940fb0e755c8621d45a45a4381b064c0e18b9c134560e9a322d9c321453b01c3b05991d7d37467ea90f01 SHA512 774cea12339b19c7d33d034e75386415b89c59de1e149f3973bd0cf789a28c4cb1cdb026a897228303071dc05f985d4798924c6b253e964d6bdced877ab9f1e7
+DIST texstudio-2.12.10.tar.gz 26770850 BLAKE2B 7dba024c34f6cf53ff8cfa21eedb53bbf7fb5aba0b00d1c7983240a46c46360bf6fdd783ec539019a9d385dd6862fc3bb9a0198c234c9546798835e1621d11ff SHA512 c3d1e14df8efe3f37dd71e5d0148f57f117c666b9487712fca5a7bd967eca4f7951c970bc5bffab14daef4fb8497af33edf2fce23cc9ae4cf598d905d9312ef0
DIST texstudio-2.12.2.tar.gz 26311798 BLAKE2B 1eb3add771a28918f39c69bb167eee31456ab87afcff0f4ae66ccd73d96fdfba5cbfbc57666908f7e7ffb5c69fd2d5aebf342338b9e3a56d3c31fb774f9cd1a7 SHA512 255b211fe715ffc91706ab20877ffaa4b8e0710d3e6f381e7a6b8eed19bb889d89d0913756839c1f0c427029c0da9713b78bd1e21769ccc46cf976b65c91c6f6
DIST texstudio-2.12.4.tar.gz 26401510 BLAKE2B 53f1aca4f28154c5ae0f941e074e2da6d727dedf6b5604b301efccd95eea256a6cb91bf887985d81c65964c0e407cd1a8c2037a3bd73559aa115bec3954df744 SHA512 6e1d114ae87c854231399004504e460d078b9bf26ceb25c7fc592b79d3234f9880f8c021c3ddb2ef26a883dbddc2b94f98f368c976aa16973d3c1a6823a4150d
DIST texstudio-2.12.6.tar.gz 26511069 BLAKE2B 95f2043222e15f96ed56dabb9bbbb937e3f8f1869cb667897bbdb48b99626089bf14a5e321c57ca5c9196d1cf2ce0beaad322b04d90f8a0b62189ff7c5be0d33 SHA512 16e846137b529f89f10dba3f847afe5a875ce1bc4029d002f76a1bcde491dd44756b27e38b4c5c159fcdb12b025759c8a0ebbbb8d8bd296e954b53032434170a
diff --git a/app-office/texstudio/texstudio-2.12.10.ebuild b/app-office/texstudio/texstudio-2.12.10.ebuild
new file mode 100644
index 000000000000..eb4cdb1b7549
--- /dev/null
+++ b/app-office/texstudio/texstudio-2.12.10.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils prefix qmake-utils xdg-utils
+
+DESCRIPTION="Free cross-platform LaTeX editor (fork from texmakerX)"
+HOMEPAGE="https://www.texstudio.org https://github.com/texstudio-org/texstudio"
+SRC_URI="https://github.com/texstudio-org/texstudio/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="video"
+
+COMMON_DEPEND="
+ app-text/hunspell:=
+ app-text/poppler[qt5]
+ >=dev-libs/quazip-0.7.2[qt5(+)]
+ dev-qt/designer:5
+ dev-qt/qtcore:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtscript:5
+ dev-qt/qtsingleapplication[qt5(+),X]
+ dev-qt/qtsvg:5
+ dev-qt/qttest:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXext
+ video? ( media-libs/phonon[qt5(+)] )"
+RDEPEND="${COMMON_DEPEND}
+ app-text/ghostscript-gpl
+ app-text/psutils
+ media-libs/netpbm
+ virtual/latex-base"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ # TODO: find hunspell quazip utilities/poppler-data qtsingleapplication -delete || die
+
+ if use video; then
+ sed "/^PHONON/s:$:true:g" -i ${PN}.pro || die
+ fi
+
+ sed \
+ -e '/qtsingleapplication.pri/d' \
+ -i ${PN}.pro || die
+
+ cp "${FILESDIR}"/texmakerx_my.pri ${PN}.pri || die
+ eprefixify ${PN}.pri
+
+ # fix build with quazip-0.7.2 - bug 597930
+ sed -i ${PN}.pro -e "s|include/quazip|&5|" || die
+ sed -i ${PN}.pri -i ${PN}.pro -e "s/-lquazip/&5/" || die
+}
+
+src_configure() {
+ eqmake5 USE_SYSTEM_HUNSPELL=1 USE_SYSTEM_QUAZIP=1
+}
+
+src_install() {
+ local i
+ for i in 16x16 22x22 32x32 48x48 64x64 128x128; do
+ newicon -s ${i} utilities/${PN}${i}.png ${PN}.png
+ done
+ emake DESTDIR="${D}" INSTALL_ROOT="${ED}" install
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}