summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2020-03-06 01:06:29 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2020-03-06 01:06:29 +0000
commitd0d28f24ad65f56e6237e6af4e84b61ecffa3878 (patch)
treeb7455adbc4a45509bc977efcee24199cb4950c65
parent2020-03-06 00:07:44 UTC (diff)
parentdev-libs/libappindicator: Drop slot 2 (diff)
downloadgentoo-d0d28f24ad65f56e6237e6af4e84b61ecffa3878.tar.gz
gentoo-d0d28f24ad65f56e6237e6af4e84b61ecffa3878.tar.bz2
gentoo-d0d28f24ad65f56e6237e6af4e84b61ecffa3878.zip
Merge updates from master
-rw-r--r--dev-libs/libappindicator/libappindicator-12.10.0-r202.ebuild90
-rw-r--r--dev-perl/Gtk2-AppIndicator/Gtk2-AppIndicator-0.150.0-r1.ebuild24
-rw-r--r--dev-perl/Gtk2-AppIndicator/Manifest1
-rw-r--r--dev-perl/Gtk2-AppIndicator/metadata.xml12
-rw-r--r--profiles/package.mask6
-rw-r--r--x11-plugins/pidgin-indicator/Manifest1
-rw-r--r--x11-plugins/pidgin-indicator/metadata.xml8
-rw-r--r--x11-plugins/pidgin-indicator/pidgin-indicator-1.0.ebuild31
8 files changed, 0 insertions, 173 deletions
diff --git a/dev-libs/libappindicator/libappindicator-12.10.0-r202.ebuild b/dev-libs/libappindicator/libappindicator-12.10.0-r202.ebuild
deleted file mode 100644
index a7f45aa66b78..000000000000
--- a/dev-libs/libappindicator/libappindicator-12.10.0-r202.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-VALA_USE_DEPEND="vapigen"
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit autotools eutils ltprune multilib-minimal python-single-r1 vala xdg-utils
-
-DESCRIPTION="A library to allow applications to export a menu into the Unity Menu bar"
-HOMEPAGE="https://launchpad.net/libappindicator"
-SRC_URI="https://launchpad.net/${PN}/${PV%.*}/${PV}/+download/${P}.tar.gz"
-
-LICENSE="LGPL-2.1 LGPL-3"
-SLOT="2"
-KEYWORDS="amd64 ~arm x86"
-
-IUSE="+introspection python"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- >=dev-libs/dbus-glib-0.98[${MULTILIB_USEDEP}]
- >=dev-libs/glib-2.26:2[${MULTILIB_USEDEP}]
- >=dev-libs/libdbusmenu-0.6.2[gtk,${MULTILIB_USEDEP}]
- >=dev-libs/libindicator-12.10.0:0[${MULTILIB_USEDEP}]
- x11-libs/gtk+:2[${MULTILIB_USEDEP},introspection?]
- introspection? ( >=dev-libs/gobject-introspection-1:= )
- python? (
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-python/pygtk[${PYTHON_MULTI_USEDEP}]
- ')
- )
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig[${MULTILIB_USEDEP}]
- introspection? ( $(vala_depend) )
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-conditional-py-bindings.patch
- # http://bazaar.launchpad.net/~indicator-applet-developers/libappindicator/trunk.12.10/revision/244
- "${FILESDIR}"/${P}-vala-inherit.patch
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
- export MAKEOPTS+=" -j1" #638782
-}
-
-src_prepare() {
- default
-
- xdg_environment_reset
-
- # Don't use -Werror
- sed -i -e 's/ -Werror//' {src,tests}/Makefile.{am,in} || die
-
- eautoreconf
-
- # Disable MONO for now because of https://bugs.gentoo.org/382491
- sed -i -e '/^MONO_REQUIRED_VERSION/s:=.*:=9999:' configure || die
-}
-
-multilib_src_configure() {
- if multilib_is_native_abi; then
- local -x VALAC VALA_API_GEN VAPIGEN_VAPIDIR PKG_CONFIG_PATH
- use introspection && vala_src_prepare && export VALA_API_GEN="${VAPIGEN}"
- fi
-
- ECONF_SOURCE=${S} \
- econf \
- --disable-static \
- --with-gtk=2 \
- $(multilib_native_use_enable introspection) \
- $(multilib_native_use_enable python)
-}
-
-multilib_src_install() {
- emake -j1 DESTDIR="${D}" install
-}
-
-multilib_src_install_all() {
- einstalldocs
- prune_libtool_files --modules
-
- # installed by slot 3 as well
- rm -r "${D}"usr/share/gtk-doc || die
-}
diff --git a/dev-perl/Gtk2-AppIndicator/Gtk2-AppIndicator-0.150.0-r1.ebuild b/dev-perl/Gtk2-AppIndicator/Gtk2-AppIndicator-0.150.0-r1.ebuild
deleted file mode 100644
index 3984a0708caf..000000000000
--- a/dev-perl/Gtk2-AppIndicator/Gtk2-AppIndicator-0.150.0-r1.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DIST_AUTHOR=OESTERHOL
-DIST_VERSION=0.15
-inherit virtualx perl-module
-
-DESCRIPTION="Perl binding for the GTK2 AppIndicator"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=dev-perl/Gtk2-1.200.0
- dev-libs/libappindicator:2
-"
-DEPEND="${RDEPEND}
- virtual/perl-ExtUtils-MakeMaker
-"
-src_test() {
- virtx perl-module_src_test
-}
diff --git a/dev-perl/Gtk2-AppIndicator/Manifest b/dev-perl/Gtk2-AppIndicator/Manifest
deleted file mode 100644
index 77cfc600fedf..000000000000
--- a/dev-perl/Gtk2-AppIndicator/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST Gtk2-AppIndicator-0.15.tar.gz 15662 BLAKE2B 59767f0d85bd2fce723c0739e3229e2200d5aea1c9d008d44dfe087bed70f408c7db90dbadf81ea64af29e89923e29aa578b89c145f41f2a25b1f08f58033ec8 SHA512 16aaddf520ce720969775b49697b605e0dda7ed3b62bb7edeefbc2c48a1122656469068b179acbfd595ae9b1f0328747898a54e7afdaf71ae7445792afd9c4ea
diff --git a/dev-perl/Gtk2-AppIndicator/metadata.xml b/dev-perl/Gtk2-AppIndicator/metadata.xml
deleted file mode 100644
index c893c255130b..000000000000
--- a/dev-perl/Gtk2-AppIndicator/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>perl@gentoo.org</email>
- <name>Gentoo Perl Project</name>
- </maintainer>
- <upstream>
- <remote-id type="cpan">Gtk2-AppIndicator</remote-id>
- <remote-id type="cpan-module">Gtk2::AppIndicator</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index f995c3d75ee9..0d28e4768f85 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -403,12 +403,6 @@ sys-firmware/iwl6050-ucode
# Mask until sys-libs/libxcrypt[system] is unmasked
>=virtual/libcrypt-2
-# Andreas Sturmlechner <asturm@gentoo.org> (2020-02-05)
-# Blocks dev-python/pygtk removal, bug #706478. Masked for removal in 30 days.
-dev-libs/libappindicator:2
-dev-perl/Gtk2-AppIndicator
-x11-plugins/pidgin-indicator
-
# Michał Górny <mgorny@gentoo.org> (2020-02-05)
# Unmaintained. No Python 3 support. Last release ~2014, homepage
# gone.
diff --git a/x11-plugins/pidgin-indicator/Manifest b/x11-plugins/pidgin-indicator/Manifest
deleted file mode 100644
index 3065fae466db..000000000000
--- a/x11-plugins/pidgin-indicator/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST pidgin-indicator-1.0.tar.gz 29583 BLAKE2B d39ef5b3ac5da87c736c2e74b7966c7009bacefe770eb833d18a8508b2bc340c5636ee3d9eed88af0ef7f385c2a9b52b16a1c4029e4d6fd35cd6b4e364c94c28 SHA512 9aa9847cb6e3c988ed4bf0666ad94139b3d3aa1b9fa4215a2d5a72cbde4db9cfdd809ab576c5ab060c33e3e89acd0ede9cde0f3d8a26bef2c5f5f46052a05102
diff --git a/x11-plugins/pidgin-indicator/metadata.xml b/x11-plugins/pidgin-indicator/metadata.xml
deleted file mode 100644
index 9dffad7f0433..000000000000
--- a/x11-plugins/pidgin-indicator/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="github">philipl/pidgin-indicator</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/x11-plugins/pidgin-indicator/pidgin-indicator-1.0.ebuild b/x11-plugins/pidgin-indicator/pidgin-indicator-1.0.ebuild
deleted file mode 100644
index ab3ceb771802..000000000000
--- a/x11-plugins/pidgin-indicator/pidgin-indicator-1.0.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools
-
-DESCRIPTION="Indicator plugin for Pidgin"
-HOMEPAGE="https://github.com/philipl/pidgin-indicator"
-SRC_URI="https://github.com/philipl/pidgin-indicator/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-RDEPEND="dev-libs/glib:2
- dev-libs/libappindicator:2
- net-im/pidgin[gtk]
- x11-libs/gtk+:2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- eautoreconf
-}
-
-src_install() {
- default
- find "${D}" -name "*.la" -exec rm {} + || die
-}