summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2024-08-18 12:28:01 -0700
committerZac Medico <zmedico@gentoo.org>2024-08-18 12:33:04 -0700
commit6b1059633c5956e575d7468a65ad57564190f91e (patch)
tree5b27a4cc30fe8e0597912ebadc8d25cf49a841f4
parentmedia-libs/glycin-loaders: Enable testing (diff)
downloadgentoo-6b1059633c5956e575d7468a65ad57564190f91e.tar.gz
gentoo-6b1059633c5956e575d7468a65ad57564190f91e.tar.bz2
gentoo-6b1059633c5956e575d7468a65ad57564190f91e.zip
dev-go/go-tools: add 0.24.0
Tested with go-1.23.0 and it successfully built all of the expected binaries. Closes: https://bugs.gentoo.org/937934 Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--dev-go/go-tools/Manifest2
-rw-r--r--dev-go/go-tools/go-tools-0.24.0.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-go/go-tools/Manifest b/dev-go/go-tools/Manifest
index 69c562a90597..e98c5f7e0f5b 100644
--- a/dev-go/go-tools/Manifest
+++ b/dev-go/go-tools/Manifest
@@ -2,3 +2,5 @@ DIST go-tools-0.1.10-deps.tar.xz 16247548 BLAKE2B 7dc27e377eec3c7fa49d37614d2b7b
DIST go-tools-0.1.10.tar.gz 3014465 BLAKE2B f3b6129ad00385539eab3426bc542a120bd41d3984174d5d8b91bee6435d7a179c0058f2a50de3235a07e5b67f6d9657288bd578591d61187447441bb6408e76 SHA512 9c817c98739a1788b7fb459728528b5c647226e64df495661c1b3027bfa571e884d6c28d8796558b65e2ba54774976897bddcd052568f33d4e30ce8ee5d883e1
DIST go-tools-0.20.0-deps.tar.xz 383336 BLAKE2B 0bddd81087bae28c2d874a2ea647a5293b32895fded73351813c1542066d7ee1a0d3d8a0aaa5c13cea3e117c692b46690282f992293d83c8fbd2901adc71911f SHA512 eeaa8a85ec81eed757156f99d6bc99f69c89debf52eb862e870c7effb7a0b800736e04f507efa19be122a5246aed2519d4c33bd850bc790947f065ab8a87a323
DIST go-tools-0.20.0.tar.gz 3779878 BLAKE2B 42175d921dfb5acb25c9eee224138675619860aefaca09db8e354481c146faa52b2fcc64d99953d8508a79ce8375ebcc42a1e7d20f4721e55b8c843989565fbc SHA512 c67706593d0a48f941955e40cadc1e39961b07ba51c9342b302ba99f93a1e55b9feec21d6171ee370f96293253be27b480274d48a16eff1055373f81b73f2dd9
+DIST go-tools-0.24.0-deps.tar.xz 423048 BLAKE2B 0df1a18476c207e26c5397aa81d475e96ac00cbf9460899c3e66804963b5661befcd648f0bc51bf67775b533c370dcf634939bd6c5efad5ee289f73233c09b66 SHA512 f4eb6bfc918b947b6903e260edc99f71ebea4b8c39a118526608b9c86712e97029ab4473fd617dc8377a7021a8b606d267abf686c4a36a37556f828afd53fb4c
+DIST go-tools-0.24.0.tar.gz 6977100 BLAKE2B ca0a9c5d3e41ca9accbacfc4074827bb3750c7bab8b20a80c76998dc4078d889eeaaf0f7fc6cd3864b5613c8474175d626165a5e20ada12876afa0279d325887 SHA512 bb41b620d4e3fe2c028a618656b47e28e9ecf2ecc49bb70dcd919948d0c6a4eeeded04ef2fa7604307029686605d5d809ff671dc1b0d3143af7100e4e480a444
diff --git a/dev-go/go-tools/go-tools-0.24.0.ebuild b/dev-go/go-tools/go-tools-0.24.0.ebuild
new file mode 100644
index 000000000000..fedb0f72416a
--- /dev/null
+++ b/dev-go/go-tools/go-tools-0.24.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="Tools that support the Go programming language (godoc, etc.)"
+HOMEPAGE="https://godoc.org/golang.org/x/tools"
+SRC_URI="https://github.com/golang/tools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~zmedico/dist/${P}-deps.tar.xz"
+S=${WORKDIR}/${P#go-}
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+# Many test failures.
+RESTRICT="test"
+
+GO_TOOLS_BINS=(
+ authtest benchcmp bisect bundle callgraph compilebench cookieauth
+ deadcode defers digraph eg fieldalignment file2fuzz findcall fiximports
+ fuzz-driver fuzz-runner gitauth go-contrib-init godex godoc goimports
+ gomvpkg gonew gopackages gorename gostacks gotype goyacc html2article
+ httpmux ifaceassert lostcancel netrcauth nilness nodecount play present
+ present2md shadow splitdwarf ssadump stress stringer stringintconv
+ toolstash unmarshal unusedresult
+)
+
+src_compile() {
+ local bin packages
+ readarray -t packages < <(ego list ./...)
+ GOBIN="${S}/bin" nonfatal ego install -work "${packages[@]}" || true
+ for bin in "${GO_TOOLS_BINS[@]}"; do
+ [[ -x ${S}/bin/${bin} ]] || \
+ die "File not found, check build log: ${S}/bin/${bin}"
+ done
+}
+
+src_test() {
+ ego test -work ./...
+}
+
+src_install() {
+ # bug 558818: install binaries in $GOROOT/bin to avoid file collisions
+ local goroot=$(go env GOROOT)
+ goroot=${goroot#${EPREFIX}}
+ exeinto "${goroot}/bin"
+ doexe bin/*
+ dodir /usr/bin
+ ln "${ED}/${goroot}/bin/godoc" "${ED}/usr/bin/godoc" || die
+}