summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-08-18 20:42:49 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-08-18 20:42:49 +0300
commit57cd83727de9dae3268a88ba7ab47ce35dfe069e (patch)
treeffdb33732a39c2f6a6f871ae57584bcf064b0edb
parentapp-vim/nerdtree: fix missing src_install (diff)
downloadgentoo-57cd83727de9dae3268a88ba7ab47ce35dfe069e.tar.gz
gentoo-57cd83727de9dae3268a88ba7ab47ce35dfe069e.tar.bz2
gentoo-57cd83727de9dae3268a88ba7ab47ce35dfe069e.zip
app-vim/gundo: EAPI=8, enable py3.11, py3.12
Closes: https://bugs.gentoo.org/929372 Closes: https://bugs.gentoo.org/896650 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--app-vim/gundo/gundo-2.6.2-r4.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-vim/gundo/gundo-2.6.2-r4.ebuild b/app-vim/gundo/gundo-2.6.2-r4.ebuild
new file mode 100644
index 000000000000..32c0758b25dd
--- /dev/null
+++ b/app-vim/gundo/gundo-2.6.2-r4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit vim-plugin python-single-r1 vcs-snapshot
+
+DESCRIPTION="vim plugin: visualize your vim undo tree"
+HOMEPAGE="https://github.com/sjl/gundo.vim"
+SRC_URI="https://github.com/sjl/gundo.vim/archive/v${PV}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ || (
+ app-editors/vim[python,${PYTHON_SINGLE_USEDEP}]
+ app-editors/gvim[python,${PYTHON_SINGLE_USEDEP}]
+ )
+ ${PYTHON_DEPS}"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+PATCHES=( "${FILESDIR}"/${P}-python3.patch )
+
+src_prepare() {
+ rm -r site tests || die
+ default
+}