summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2021-06-21 06:24:37 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2021-06-21 06:24:37 +0000
commit1478f86533ca9d9e4812d06b78e0387072160fac (patch)
tree0bbb550285710a388f68968c2c048a9776b85749
parent2021-06-21 05:57:36 UTC (diff)
parenteutils.eclass: update die message for EAPI 0 (diff)
downloadgentoo-1478f86533ca9d9e4812d06b78e0387072160fac.tar.gz
gentoo-1478f86533ca9d9e4812d06b78e0387072160fac.tar.bz2
gentoo-1478f86533ca9d9e4812d06b78e0387072160fac.zip
Merge updates from master
-rw-r--r--dev-python/leather/Manifest1
-rw-r--r--dev-python/leather/leather-0.3.3.ebuild17
-rw-r--r--dev-python/leather/metadata.xml13
-rw-r--r--eclass/eutils.eclass2
4 files changed, 32 insertions, 1 deletions
diff --git a/dev-python/leather/Manifest b/dev-python/leather/Manifest
new file mode 100644
index 000000000000..0d3da570b053
--- /dev/null
+++ b/dev-python/leather/Manifest
@@ -0,0 +1 @@
+DIST leather-0.3.3.tar.gz 18391 BLAKE2B 0a81343251fcdea85873fea023e1d709a385b268c2900642764c1a0ae6abfa84d9dece0ef67ae152b716c93c1bdaf9671f8c5df8cf5605694af48e8f3552437a SHA512 3387353d4da129fa3601799efe8742aea08f94579caab7a5a05175ff7ad50a815fc7ca4aee5d1c390027bda3a9bf1ecd1ed5167575386a7a58f56625f5165350
diff --git a/dev-python/leather/leather-0.3.3.ebuild b/dev-python/leather/leather-0.3.3.ebuild
new file mode 100644
index 000000000000..75f887373270
--- /dev/null
+++ b/dev-python/leather/leather-0.3.3.ebuild
@@ -0,0 +1,17 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Python charting for 80% of humans."
+HOMEPAGE="https://github.com/wireservice/leather https://pypi.org/project/leather/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RDEPEND=">=dev-python/six-1.6.1[${PYTHON_USEDEP}]"
diff --git a/dev-python/leather/metadata.xml b/dev-python/leather/metadata.xml
new file mode 100644
index 000000000000..2b9e7e0da02b
--- /dev/null
+++ b/dev-python/leather/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/wireservice/leather/issues</bugs-to>
+ <changelog>https://github.com/wireservice/leather/commits/master</changelog>
+ <remote-id type="pypi">leather</remote-id>
+ <remote-id type="github">wireservice/leather</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/eclass/eutils.eclass b/eclass/eutils.eclass
index 1af5fbda513f..ef663f3095a9 100644
--- a/eclass/eutils.eclass
+++ b/eclass/eutils.eclass
@@ -29,7 +29,7 @@ case ${EAPI:-0} in
preserve-libs toolchain-funcs vcs-clean wrapper
;;
7) inherit edos2unix l10n wrapper ;;
- *) die "${ECLASS} is banned in EAPI ${EAPI}" ;;
+ *) die "${ECLASS} is banned in EAPI ${EAPI:-0}" ;;
esac
# @FUNCTION: emktemp