aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <stefan.strogin@gmail.com>2019-03-25 07:40:09 +0200
committerStefan Strogin <stefan.strogin@gmail.com>2019-03-25 07:40:09 +0200
commit81907d2f76c51dbc3de6f01843de103cc8bfd635 (patch)
tree5c8d631e029bea9c866c5903dacf577ac0eaba60 /dev-perl/Net-SSLeay
parentdev-qt/qtnetwork: bump version to 5.12.2 (diff)
downloadlibressl-81907d2f76c51dbc3de6f01843de103cc8bfd635.tar.gz
libressl-81907d2f76c51dbc3de6f01843de103cc8bfd635.tar.bz2
libressl-81907d2f76c51dbc3de6f01843de103cc8bfd635.zip
dev-perl/Net-SSLeay: add version 1.860.0_p9
This version supports LibreSSL 2.9.0 out of box. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
Diffstat (limited to 'dev-perl/Net-SSLeay')
-rw-r--r--dev-perl/Net-SSLeay/Manifest1
-rw-r--r--dev-perl/Net-SSLeay/Net-SSLeay-1.860.0_p9.ebuild62
-rw-r--r--dev-perl/Net-SSLeay/files/Net-SSLeay-1.86-fix-libdir.patch27
-rw-r--r--dev-perl/Net-SSLeay/metadata.xml13
4 files changed, 103 insertions, 0 deletions
diff --git a/dev-perl/Net-SSLeay/Manifest b/dev-perl/Net-SSLeay/Manifest
new file mode 100644
index 0000000..e14a4f6
--- /dev/null
+++ b/dev-perl/Net-SSLeay/Manifest
@@ -0,0 +1 @@
+DIST Net-SSLeay-1.86_09.tar.gz 430456 BLAKE2B c16cba2a1252d572d828e0f3a7cf708ab5bb2369998e949e95edba0098fa5b2c26b724c1029fad63ba4fa200280696035bcb83682214559e0dc09b446d245b89 SHA512 5f878169075dac9b0e5f9aabec732a5034858a414a8344d16928fe8ec614277872d3af75295ac065ef5a7511c0f5ca22fc3f5cd040f0009d2a8119314da54727
diff --git a/dev-perl/Net-SSLeay/Net-SSLeay-1.860.0_p9.ebuild b/dev-perl/Net-SSLeay/Net-SSLeay-1.860.0_p9.ebuild
new file mode 100644
index 0000000..6180799
--- /dev/null
+++ b/dev-perl/Net-SSLeay/Net-SSLeay-1.860.0_p9.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=CHRISN
+DIST_VERSION=1.86_09
+DIST_EXAMPLES=("examples/*")
+inherit multilib perl-module
+
+DESCRIPTION="Perl extension for using OpenSSL"
+
+LICENSE="openssl"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="libressl test minimal examples"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ virtual/perl-MIME-Base64
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ !minimal? (
+ dev-perl/Test-Exception
+ dev-perl/Test-Warn
+ dev-perl/Test-NoWarnings
+ )
+ virtual/perl-Test-Simple
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.86-fix-libdir.patch"
+)
+PERL_RM_FILES=(
+ # Hateful author tests
+ 't/local/01_pod.t'
+ 't/local/02_pod_coverage.t'
+ 't/local/kwalitee.t'
+ # Broken under FEATURES="network-sandbox"
+ # https://rt.cpan.org/Ticket/Display.html?id=128207
+ 't/local/06_tcpecho.t'
+ 't/local/07_sslecho.t'
+)
+mymake=(
+ OPTIMIZE="${CFLAGS}"
+ OPENSSL_PREFIX="${EPREFIX}"/usr
+)
+
+src_configure() {
+ if use test && has network ${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}; then
+ export NETWORK_TESTS=yes
+ else
+ use test && einfo "Network tests will be skipped without DIST_TEST_OVERRIDE=~network"
+ export NETWORK_TESTS=no
+ fi
+ export LIBDIR=$(get_libdir)
+ perl-module_src_configure
+}
diff --git a/dev-perl/Net-SSLeay/files/Net-SSLeay-1.86-fix-libdir.patch b/dev-perl/Net-SSLeay/files/Net-SSLeay-1.86-fix-libdir.patch
new file mode 100644
index 0000000..d78acb9
--- /dev/null
+++ b/dev-perl/Net-SSLeay/files/Net-SSLeay-1.86-fix-libdir.patch
@@ -0,0 +1,27 @@
+Bug: https://bugs.gentoo.org/416339
+
+The previous patch for the above bug report used $ENV{LIBDIR} but this
+wasn't enough to help with cross-compiling. We could use $ENV{SYSROOT}
+but this results in a bogus RPATH entry. It is better to simply trust
+the toolchain, which may have its own sysroot applied.
+
+Cross-compiling Perl modules requires additional hackery but at least
+that hackery will work now. :)
+
+Chewi
+2017/12/03
+
+diff -Naur a/Makefile.PL b/Makefile.PL
+--- a/Makefile.PL 2017-10-13 01:38:01.000000000 +0100
++++ b/Makefile.PL 2017-12-03 10:52:27.304861804 +0000
+@@ -141,10 +141,8 @@
+ cccdlflags => '',
+ };
+ for ("$prefix/include", "$prefix/inc32", '/usr/kerberos/include') {
+- push @{$opts->{inc_paths}}, $_ if -f "$_/openssl/ssl.h";
+ }
+ for ($prefix, "$prefix/lib64", "$prefix/lib", "$prefix/out32dll") {
+- push @{$opts->{lib_paths}}, $_ if -d $_;
+ }
+
+ my $rsaref = $self->ssleay_is_rsaref;
diff --git a/dev-perl/Net-SSLeay/metadata.xml b/dev-perl/Net-SSLeay/metadata.xml
new file mode 100644
index 0000000..3a182c2
--- /dev/null
+++ b/dev-perl/Net-SSLeay/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Net-SSLeay</remote-id>
+ <remote-id type="cpan-module">Net::SSLeay</remote-id>
+ <remote-id type="cpan-module">Net::SSLeay::Handle</remote-id>
+ </upstream>
+</pkgmetadata>