aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/avro')
-rw-r--r--dev-python/avro/Manifest1
-rw-r--r--dev-python/avro/avro-1.11.3.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/avro/Manifest b/dev-python/avro/Manifest
index 49da0325e..1c1556cf2 100644
--- a/dev-python/avro/Manifest
+++ b/dev-python/avro/Manifest
@@ -1 +1,2 @@
DIST avro-1.11.0.tar.gz 83374 BLAKE2B 01f63974133d2c199f2b1e50694787898505dccf9ee3100517bd783088dce47a9b7c03aa9f98c9b4bd06a989a804478e081f0068fe4f2e81c047a9579c7a395e SHA512 e5fa1842df8d1dd730da850957927049c39788ce27b8454960d88fe7e8cf6bb6537e6db2dedd630fd09c03bc736f276b567c35c749f06fdc76a6d9cac43a4c07
+DIST avro-1.11.3.tar.gz 90621 BLAKE2B 3fbd8ea80eeea212e9136207c5207af5571ad74e21d5ab469fc1a86525cffb2f80477757be8b63cd026d9b75ec596d30b2c1bdf4abba6b15711cd3dffafcf80e SHA512 2f7877dce1ff2bde8e9cbf531f8c8149c68026ee9274d53bcbe99e7ecb678004701ad5c7cb001c01c0351aaa4d8b5d5d699f8952d95368ad2713204dd1c21895
diff --git a/dev-python/avro/avro-1.11.3.ebuild b/dev-python/avro/avro-1.11.3.ebuild
new file mode 100644
index 000000000..f09b598b4
--- /dev/null
+++ b/dev-python/avro/avro-1.11.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Apache Avro is a data serialization system"
+HOMEPAGE="
+ https://pypi.org/project/avro/
+ https://avro.apache.org
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="test"
+PROPERTIES="test_network"
+
+distutils_enable_tests pytest