aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-03-18 10:42:08 +0100
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-03-18 10:48:50 +0100
commit87de5d9f3216edc0f1ecdabb0bfa9fe6057dd3de (patch)
treed1c815365d37711756ee5bf4b2646a985bf48ec1 /dev-python/nosehtmloutput
parentdev-python/orjson: add 3.6.7 (diff)
downloadguru-87de5d9f3216edc0f1ecdabb0bfa9fe6057dd3de.tar.gz
guru-87de5d9f3216edc0f1ecdabb0bfa9fe6057dd3de.tar.bz2
guru-87de5d9f3216edc0f1ecdabb0bfa9fe6057dd3de.zip
dev-python/nosehtmloutput: initial import
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-python/nosehtmloutput')
-rw-r--r--dev-python/nosehtmloutput/Manifest1
-rw-r--r--dev-python/nosehtmloutput/metadata.xml12
-rw-r--r--dev-python/nosehtmloutput/nosehtmloutput-0.0.7.ebuild27
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/nosehtmloutput/Manifest b/dev-python/nosehtmloutput/Manifest
new file mode 100644
index 000000000..1931a9e9a
--- /dev/null
+++ b/dev-python/nosehtmloutput/Manifest
@@ -0,0 +1 @@
+DIST nosehtmloutput-0.0.7.tar.gz 7582 BLAKE2B 6f2155358d91491fa42238404548379fa8046bdc8d81f4d2f7520330477032fb01838a0055838b2ac230cfc3804eaa22488e836d2afa553e54318e762e3eb543 SHA512 29461eec7f6f5c642730090fe93c1ecda9e0bb4e26bb977866c161854b5d4ec9cf037b1531b881d9504629dbddb8bc65888a416d14d99357dec99acd56ec553d
diff --git a/dev-python/nosehtmloutput/metadata.xml b/dev-python/nosehtmloutput/metadata.xml
new file mode 100644
index 000000000..dbdafb32b
--- /dev/null
+++ b/dev-python/nosehtmloutput/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">nosehtmloutput</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/nosehtmloutput/nosehtmloutput-0.0.7.ebuild b/dev-python/nosehtmloutput/nosehtmloutput-0.0.7.ebuild
new file mode 100644
index 000000000..7d22f4758
--- /dev/null
+++ b/dev-python/nosehtmloutput/nosehtmloutput-0.0.7.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION=""
+HOMEPAGE="
+ https://opendev.org/openstack/nose-html-output
+ https://pypi.org/project/nosehtmloutput/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests nose