aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-05-18 02:00:28 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-05-18 17:41:08 +0200
commita7f518d1754e7c34cd2e51ecf92353b56711a82c (patch)
treed041644cbc8e10e9001f2fcf304719d14e9fbc9a
parentdev-python/pytest-travis-fold: pypy3 added (diff)
downloadguru-a7f518d1754e7c34cd2e51ecf92353b56711a82c.tar.gz
guru-a7f518d1754e7c34cd2e51ecf92353b56711a82c.tar.bz2
guru-a7f518d1754e7c34cd2e51ecf92353b56711a82c.zip
dev-python/atomiclong: pypy3 added
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-python/atomiclong/atomiclong-0.1.1-r1.ebuild20
-rw-r--r--dev-python/atomiclong/atomiclong-9999.ebuild2
2 files changed, 21 insertions, 1 deletions
diff --git a/dev-python/atomiclong/atomiclong-0.1.1-r1.ebuild b/dev-python/atomiclong/atomiclong-0.1.1-r1.ebuild
new file mode 100644
index 000000000..475c98dcf
--- /dev/null
+++ b/dev-python/atomiclong/atomiclong-0.1.1-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( pypy3 python3_{6,7} )
+
+inherit distutils-r1
+
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+DESCRIPTION="An AtomicLong type using CFFI."
+HOMEPAGE="https://github.com/dreid/atomiclong"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="virtual/python-cffi[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
diff --git a/dev-python/atomiclong/atomiclong-9999.ebuild b/dev-python/atomiclong/atomiclong-9999.ebuild
index 87c8abf50..c225edae4 100644
--- a/dev-python/atomiclong/atomiclong-9999.ebuild
+++ b/dev-python/atomiclong/atomiclong-9999.ebuild
@@ -3,7 +3,7 @@
EAPI="7"
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( pypy3 python3_{6,7} )
inherit distutils-r1