aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-05-17 10:48:42 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-05-18 17:41:08 +0200
commit6f07b7b3614912ed90c77bc88e1bb5080741e038 (patch)
tree7cbd6b9a8af2096326feadbfe3361a06e72cead0
parentdev-python/websockets: older version (diff)
downloadguru-6f07b7b3614912ed90c77bc88e1bb5080741e038.tar.gz
guru-6f07b7b3614912ed90c77bc88e1bb5080741e038.tar.bz2
guru-6f07b7b3614912ed90c77bc88e1bb5080741e038.zip
dev-python/sanic: new version
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-python/sanic/Manifest1
-rw-r--r--dev-python/sanic/sanic-20.3.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/sanic/Manifest b/dev-python/sanic/Manifest
index c4f1f4dd7..30b9cc758 100644
--- a/dev-python/sanic/Manifest
+++ b/dev-python/sanic/Manifest
@@ -1 +1,2 @@
DIST sanic-19.12.2.tar.gz 195755 BLAKE2B 0d903b06403f28a901d21bfc685219064d0ec2b11576baf714aa3250cc3474928da03c34f0a5a25bf92191242b0a41f76d41aabe92a805bea1801e569c892e9a SHA512 93e416ceea5577db4c443dd6dd03cc5e990d4f987d49821b70d5602421d38401e155e2aad166c88ec57fc5361350c641f087b461a6d92acde34455db81429c5c
+DIST sanic-20.3.0.tar.gz 200120 BLAKE2B 14c648f6607b924ee8c19a481b027866a1e24b13249129d3e3fd2ebaf48243ec30d800cd0f62f3f361ae265ef4139676b5aaa4d5481e57459360df11d9fb5c8d SHA512 05615b2b0a2f3b03b2cdf6cff9d2df6f95a54c12be98b54674a2060104327e9a98db55b5e9fbc608f4e624abbb68e7b2f169df26c8197669aad05a4e15ac3ee7
diff --git a/dev-python/sanic/sanic-20.3.0.ebuild b/dev-python/sanic/sanic-20.3.0.ebuild
new file mode 100644
index 000000000..acd563f8c
--- /dev/null
+++ b/dev-python/sanic/sanic-20.3.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="Async Python 3.6+ web server/framework | Build fast. Run fast."
+HOMEPAGE="
+ https://pypi.python.org/pypi/sanic
+ https://github.com/huge-success/sanic
+"
+SRC_URI="https://github.com/huge-success/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/aiofiles[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.11.1[${PYTHON_USEDEP}]
+ >=dev-python/httptools-0.0.10[${PYTHON_USEDEP}]
+ >=dev-python/multidict-4.0[${PYTHON_USEDEP}]
+ <dev-python/multidict-5.0[${PYTHON_USEDEP}]
+ >=dev-python/ujson-1.35[${PYTHON_USEDEP}]
+ >=dev-python/uvloop-0.5.3[${PYTHON_USEDEP}]
+ >=dev-python/websockets-7.0[${PYTHON_USEDEP}]
+ <dev-python/websockets-8.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/beautifulsoup[${PYTHON_USEDEP}]
+ >=dev-python/httpcore-0.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-5.2.1[${PYTHON_USEDEP}]
+ dev-python/pytest-benchmark[${PYTHON_USEDEP}]
+ dev-python/pytest-sanic[${PYTHON_USEDEP}]
+ dev-python/pytest-sugar[${PYTHON_USEDEP}]
+ dev-python/uvicorn[${PYTHON_USEDEP}]
+ www-servers/gunicorn[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/docutils \
+ dev-python/pygments \
+ ">=dev-python/sphinx-2.1.2" \
+ ">=dev-python/sphinx_rtd_theme-0.4.3" \
+ ">=dev-python/recommonmark-0.5.0" \
+ www-servers/gunicorn