From b614255a729079af4d5d4073de10cb38ef6b9149 Mon Sep 17 00:00:00 2001
From: Aron Griffis <agriffis@gentoo.org>
Date: Fri, 22 Jul 2005 19:01:29 +0000
Subject: Require mozilla-launcher-1.41 so that we can get rid of
 nsplugins.eclass and stop calling src_mv_plugins and pkg_mv_plugins.  Don't
 drop in initial tarball because it is no longer necessary.  However, don't
 attempt to call mozilla-launcher -register either, because the -bin packages
 don't provide regchrome and regxpcom.  This is fine, doesn't matter for a
 fresh install, just means that we won't be able to install extensions via
 portage for the -bin ebuilds. Package-Manager: portage-2.0.51.22-r2

---
 www-client/mozilla-firefox-bin/ChangeLog           | 14 ++++-
 www-client/mozilla-firefox-bin/Manifest            |  8 ++-
 .../files/digest-mozilla-firefox-bin-1.0.6-r1      |  1 +
 .../mozilla-firefox-bin-1.0.6-r1.ebuild            | 68 ++++++++++++++++++++++
 4 files changed, 87 insertions(+), 4 deletions(-)
 create mode 100644 www-client/mozilla-firefox-bin/files/digest-mozilla-firefox-bin-1.0.6-r1
 create mode 100644 www-client/mozilla-firefox-bin/mozilla-firefox-bin-1.0.6-r1.ebuild

(limited to 'www-client/mozilla-firefox-bin')

diff --git a/www-client/mozilla-firefox-bin/ChangeLog b/www-client/mozilla-firefox-bin/ChangeLog
index 6b3c3f567c01..aafda91645c8 100644
--- a/www-client/mozilla-firefox-bin/ChangeLog
+++ b/www-client/mozilla-firefox-bin/ChangeLog
@@ -1,6 +1,18 @@
 # ChangeLog for www-client/mozilla-firefox-bin
 # Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-firefox-bin/ChangeLog,v 1.19 2005/07/20 04:03:40 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-firefox-bin/ChangeLog,v 1.20 2005/07/22 19:01:29 agriffis Exp $
+
+*mozilla-firefox-bin-1.0.6-r1 (22 Jul 2005)
+
+  22 Jul 2005; Aron Griffis <agriffis@gentoo.org>
+  +mozilla-firefox-bin-1.0.6-r1.ebuild:
+  Require mozilla-launcher-1.41 so that we can get rid of nsplugins.eclass and
+  stop calling src_mv_plugins and pkg_mv_plugins.  Don't drop in initial tarball
+  because it is no longer necessary.  However, don't attempt to call
+  mozilla-launcher -register either, because the -bin packages don't provide
+  regchrome and regxpcom.  This is fine, doesn't matter for a fresh install, just
+  means that we won't be able to install extensions via portage for the -bin
+  ebuilds.
 
 *mozilla-firefox-bin-1.0.6 (20 Jul 2005)
 
diff --git a/www-client/mozilla-firefox-bin/Manifest b/www-client/mozilla-firefox-bin/Manifest
index 19b876789e2f..9f32d40ab1ba 100644
--- a/www-client/mozilla-firefox-bin/Manifest
+++ b/www-client/mozilla-firefox-bin/Manifest
@@ -1,9 +1,11 @@
-MD5 dc40fd69da40d642e65ef9252aed4759 ChangeLog 8863
-MD5 ce23390351fe8020387d93ee29e09a3d metadata.xml 160
 MD5 92586c93078bc7f3e744f8b90275bafa mozilla-firefox-bin-1.0.5-r1.ebuild 2420
 MD5 5b54f655265e7a335b5cd6d219c7b3d3 mozilla-firefox-bin-1.0.6.ebuild 2418
+MD5 609ab89431af221518752e49ab0e24a3 ChangeLog 9476
+MD5 ce23390351fe8020387d93ee29e09a3d metadata.xml 160
+MD5 c66dbe7521ea421095934d1122ca45e9 mozilla-firefox-bin-1.0.6-r1.ebuild 1767
 MD5 7b6378c14fc0f9bd858c2ac9abbca109 files/firefox-bin-0.9-init.tar.bz2 3327
 MD5 4b866b7683105489860f6352e8651be0 files/digest-mozilla-firefox-bin-1.0.5-r1 66
+MD5 a55b185b30df1647429525139fe29ec5 files/digest-mozilla-firefox-bin-1.0.6-r1 66
 MD5 a55b185b30df1647429525139fe29ec5 files/digest-mozilla-firefox-bin-1.0.6 66
-MD5 bff260036c5dcca45da3218517fb33d8 files/icon/mozillafirefox-bin-icon.png 3979
 MD5 dc62e3f15845b0343d1513abada402d7 files/icon/mozillafirefox-bin.desktop 203
+MD5 bff260036c5dcca45da3218517fb33d8 files/icon/mozillafirefox-bin-icon.png 3979
diff --git a/www-client/mozilla-firefox-bin/files/digest-mozilla-firefox-bin-1.0.6-r1 b/www-client/mozilla-firefox-bin/files/digest-mozilla-firefox-bin-1.0.6-r1
new file mode 100644
index 000000000000..d4c3acc92af7
--- /dev/null
+++ b/www-client/mozilla-firefox-bin/files/digest-mozilla-firefox-bin-1.0.6-r1
@@ -0,0 +1 @@
+MD5 01ff4bcf6363e3e41411b8dd39fce902 firefox-1.0.6.tar.gz 8223348
diff --git a/www-client/mozilla-firefox-bin/mozilla-firefox-bin-1.0.6-r1.ebuild b/www-client/mozilla-firefox-bin/mozilla-firefox-bin-1.0.6-r1.ebuild
new file mode 100644
index 000000000000..013bc9757e0e
--- /dev/null
+++ b/www-client/mozilla-firefox-bin/mozilla-firefox-bin-1.0.6-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-firefox-bin/mozilla-firefox-bin-1.0.6-r1.ebuild,v 1.1 2005/07/22 19:01:29 agriffis Exp $
+
+inherit eutils mozilla-launcher
+
+IUSE=""
+
+DESCRIPTION="Firefox Web Browser"
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/linux-i686/en-US/firefox-${PV}.tar.gz"
+HOMEPAGE="http://www.mozilla.org/projects/firefox"
+RESTRICT="nostrip"
+
+KEYWORDS="-* ~amd64 ~x86"
+SLOT="0"
+LICENSE="MPL-1.1 NPL-1.1"
+
+DEPEND="virtual/libc"
+RDEPEND="virtual/x11
+	x86? (
+		>=sys-libs/lib-compat-1.0-r2
+		>=x11-libs/gtk+-2.2
+	)
+	amd64? (
+		>=app-emulation/emul-linux-x86-baselibs-1.0
+		>=app-emulation/emul-linux-x86-gtklibs-1.0
+	)
+	>=www-client/mozilla-launcher-1.41"
+
+S=${WORKDIR}/firefox
+
+# This is a binary x86 package => ABI=x86
+# Please keep this in future versions
+# Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+has_multilib_profile && ABI="x86"
+
+src_install() {
+	declare MOZILLA_FIVE_HOME=/opt/firefox
+
+	# Install firefox in /opt
+	dodir ${MOZILLA_FIVE_HOME%/*}
+	mv ${S} ${D}${MOZILLA_FIVE_HOME}
+
+	# Create /usr/bin/firefox-bin
+	install_mozilla_launcher_stub firefox-bin ${MOZILLA_FIVE_HOME}
+
+	# Install icon and .desktop for menu entry
+	insinto /usr/share/pixmaps
+	doins ${FILESDIR}/icon/mozillafirefox-bin-icon.png
+	insinto /usr/share/applications
+	doins ${FILESDIR}/icon/mozillafirefox-bin.desktop
+}
+
+pkg_preinst() {
+	declare MOZILLA_FIVE_HOME=/opt/firefox
+
+	# Remove entire installed instance to prevent all kinds of
+	# problems... see bug 44772 for example
+	rm -rf "${ROOT}${MOZILLA_FIVE_HOME}"
+}
+
+pkg_postinst() {
+	update_mozilla_launcher_symlinks
+}
+
+pkg_postrm() {
+	update_mozilla_launcher_symlinks
+}
-- 
cgit v1.2.3-65-gdbad