summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/hppa-sources/hppa-sources-2.4.21_p2.ebuild')
-rw-r--r--sys-kernel/hppa-sources/hppa-sources-2.4.21_p2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-kernel/hppa-sources/hppa-sources-2.4.21_p2.ebuild b/sys-kernel/hppa-sources/hppa-sources-2.4.21_p2.ebuild
new file mode 100644
index 000000000000..2406703535e5
--- /dev/null
+++ b/sys-kernel/hppa-sources/hppa-sources-2.4.21_p2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hppa-sources/hppa-sources-2.4.21_p2.ebuild,v 1.1 2003/07/09 15:03:18 gmsoft Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+ETYPE="sources"
+inherit kernel
+OKV="${PV/_p*/}"
+PATCH_LEVEL="${PV/${OKV}_p/}"
+KV=${OKV}-pa${PATCH_LEVEL}
+EXTRAVERSION="-pa${PATCH_LEVEL}"
+S=${WORKDIR}/linux-${KV}
+
+# What's in this kernel?
+
+# INCLUDED:
+# stock 2.4.20 kernel sources
+# patches for hppa
+
+DESCRIPTION="Full sources for the Linux kernel with patch for hppa"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://ftp.parisc-linux.org/cvs/patch-${KV}.diff.gz"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/ http://parisc-linux.org"
+KEYWORDS="hppa -*"
+SLOT="${KV}"
+
+
+src_unpack() {
+ unpack linux-${OKV}.tar.bz2
+ mv ${WORKDIR}/linux-${OKV} ${WORKDIR}/linux-${KV}
+ cd ${S}
+ unpack patch-${KV}.diff.gz
+ patch -p 1 < ${S}/patch-${KV}.diff
+
+
+ kernel_universal_unpack
+}