summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/lsiutil/lsiutil-1.60-r1.ebuild')
-rw-r--r--sys-block/lsiutil/lsiutil-1.60-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-block/lsiutil/lsiutil-1.60-r1.ebuild b/sys-block/lsiutil/lsiutil-1.60-r1.ebuild
new file mode 100644
index 000000000000..74853a9ff609
--- /dev/null
+++ b/sys-block/lsiutil/lsiutil-1.60-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/lsiutil/lsiutil-1.60-r1.ebuild,v 1.1 2009/05/07 13:09:57 wschlich Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="LSI Logic Fusion MPT Command Line Interface management tool"
+HOMEPAGE="http://www.lsi.com/"
+SRC_URI="http://www.lsi.com/DistributionSystem/AssetDocument/support/downloads/hbas/fibre_channel/hardware_drivers/LSIUtil%20Kit_1.60.zip"
+
+LICENSE="LSI"
+SLOT="0"
+# This package can never enter stable, it can't be mirrored and upstream
+# can remove the distfiles from their mirror anytime.
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT="strip mirror test"
+
+RDEPEND=""
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ unpack ./Source/${PN}.tar.gz
+}
+
+src_compile() {
+ cd "${S}"/${PN}
+ $(tc-getCC) ${CFLAGS} -o ${PN} ${PN}.c || die "emake failed."
+}
+
+src_install() {
+ dosbin ${PN}/${PN} || die "dosbin failed."
+ dodoc "${S}"/*.txt
+}
+
+pkg_postinst() {
+ einfo
+ einfo "See LsiUtil_ReadMe.txt for a list of supported controllers"
+ einfo "and general usage information."
+ einfo
+}