summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/paludis/files/digest-paludis-0.6.53
-rw-r--r--sys-apps/paludis/paludis-0.6.5.ebuild65
2 files changed, 68 insertions, 0 deletions
diff --git a/sys-apps/paludis/files/digest-paludis-0.6.5 b/sys-apps/paludis/files/digest-paludis-0.6.5
new file mode 100644
index 000000000000..a8d1d7ecd685
--- /dev/null
+++ b/sys-apps/paludis/files/digest-paludis-0.6.5
@@ -0,0 +1,3 @@
+MD5 0cfa8ba2745f04830cf16027bae58189 paludis-0.6.5.tar.bz2 640670
+RMD160 a2e216f55e69c5a733c6515b9c7a58d7dbdc4022 paludis-0.6.5.tar.bz2 640670
+SHA256 ecd20b6e98361f8204f5ee37247649d57e2aad681d39b2fbe63b33a23dcb5881 paludis-0.6.5.tar.bz2 640670
diff --git a/sys-apps/paludis/paludis-0.6.5.ebuild b/sys-apps/paludis/paludis-0.6.5.ebuild
new file mode 100644
index 000000000000..949523a2354f
--- /dev/null
+++ b/sys-apps/paludis/paludis-0.6.5.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/paludis/paludis-0.6.5.ebuild,v 1.1 2006/09/23 21:54:47 spb Exp $
+
+DESCRIPTION="paludis, the other package mangler"
+HOMEPAGE="http://paludis.berlios.de/"
+SRC_URI="http://download.berlios.de/paludis/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="doc pink selinux qa"
+
+DEPEND="
+ dev-cpp/libebt
+ dev-cpp/libwrapiter
+ >=app-shells/bash-3
+ >=sys-devel/autoconf-2.59
+ =sys-devel/automake-1.9*
+ doc? ( app-doc/doxygen )
+ selinux? ( sys-libs/libselinux )
+ qa? ( dev-libs/pcre++ >=dev-libs/libxml2-2.6 )
+ dev-util/pkgconfig"
+
+RDEPEND="
+ >=app-admin/eselect-1.0.2
+ >=app-shells/bash-3
+ net-misc/wget
+ net-misc/rsync
+ qa? ( dev-libs/pcre++ >=dev-libs/libxml2-2.6 )
+ !mips? ( sys-apps/sandbox )
+ selinux? ( sys-libs/libselinux )"
+
+PROVIDE="virtual/portage"
+
+src_compile() {
+ econf \
+ $(use_enable doc doxygen ) \
+ $(use_enable !mips sandbox ) \
+ $(use_enable pink) \
+ $(use_enable selinux) \
+ $(use_enable qa) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+ if use doc ; then
+ make doxygen || die "make doxygen failed"
+ fi
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS README ChangeLog NEWS
+
+ if use doc ; then
+ dohtml -r -V doc/html/
+ fi
+}
+
+src_test() {
+ # Work around Portage bug
+ addwrite /var/cache
+ emake check || die "Make check failed"
+}
+