summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/kbd')
-rw-r--r--sys-apps/kbd/ChangeLog9
-rw-r--r--sys-apps/kbd/Manifest5
-rw-r--r--sys-apps/kbd/files/digest-kbd-1.08-r51
-rw-r--r--sys-apps/kbd/files/kbd-1.08-find-map-fix.patch35
-rw-r--r--sys-apps/kbd/kbd-1.08-r5.ebuild78
5 files changed, 126 insertions, 2 deletions
diff --git a/sys-apps/kbd/ChangeLog b/sys-apps/kbd/ChangeLog
index 40c123a0df18..b5097346b55f 100644
--- a/sys-apps/kbd/ChangeLog
+++ b/sys-apps/kbd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/kbd
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kbd/ChangeLog,v 1.22 2004/01/19 18:44:14 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kbd/ChangeLog,v 1.23 2004/01/29 00:51:55 azarah Exp $
+
+*kbd-1.08-r5 (29 Jan 2004)
+
+ 29 Jan 2004; Martin Schlemmer <azarah@gentoo.org> kbd-1.08-r5.ebuild,
+ files/kbd-1.08-find-map-fix.patch:
+ Fixes a problem where loadkeys matches dvorak the dir, and not the
+ .map file.
19 Jan 2004; Martin Schlemmer <azarah@gentoo.org> kbd-1.08-r4.ebuild:
Mark stable, as latest stable baselayout depends on it, bug #38585.
diff --git a/sys-apps/kbd/Manifest b/sys-apps/kbd/Manifest
index a368eab7fbad..4551c6ead7ce 100644
--- a/sys-apps/kbd/Manifest
+++ b/sys-apps/kbd/Manifest
@@ -1,11 +1,14 @@
-MD5 fca5e7c48a81a4278ae89e3ec27c1259 ChangeLog 4040
+MD5 31bf8d57cb351f1df860c9bb888e17a1 ChangeLog 4260
MD5 fed33c113d65cf0c5f84e221d98e8cd0 kbd-1.08-r4.ebuild 1881
+MD5 d38a4950a4e1f7f8f0fe13a56fee3dba kbd-1.08-r5.ebuild 2011
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 ce9713c16780e814e844ca87ffaa7ce4 kbd-1.06-r1.ebuild 1120
+MD5 475c159d5e9aacca7474233633b74d35 files/kbd-1.08-find-map-fix.patch 833
MD5 b1f1dbd569840cc0e1c97a7431466964 files/digest-kbd-1.06-r1 60
MD5 5b55b831e2ba400e09936d649e78a065 files/kbd-1.08-po-install-locations.patch 490
MD5 bae0fb2144b6ea25fbaacf1e36452f48 files/kbd-1.08-nowarn.patch 341
MD5 756f158177d250477cb5e2426fa5b477 files/kbd-1.08-kbd_repeat.patch 4136
+MD5 f6af43f3979cc9d66a938d22c1727388 files/digest-kbd-1.08-r5 60
MD5 86535adb8da923e0df3c58d9caa35ae6 files/kbd-1.06-othervt.patch 1605
MD5 6e007f04a80358ea81b27c80498a4808 files/kbd-1.08-terminal.patch 925
MD5 f6af43f3979cc9d66a938d22c1727388 files/digest-kbd-1.08-r4 60
diff --git a/sys-apps/kbd/files/digest-kbd-1.08-r5 b/sys-apps/kbd/files/digest-kbd-1.08-r5
new file mode 100644
index 000000000000..9b77d0dd0db3
--- /dev/null
+++ b/sys-apps/kbd/files/digest-kbd-1.08-r5
@@ -0,0 +1 @@
+MD5 924e6a05e52715dc0f96385b35f2f680 kbd-1.08.tar.gz 819924
diff --git a/sys-apps/kbd/files/kbd-1.08-find-map-fix.patch b/sys-apps/kbd/files/kbd-1.08-find-map-fix.patch
new file mode 100644
index 000000000000..bdb06d31246b
--- /dev/null
+++ b/sys-apps/kbd/files/kbd-1.08-find-map-fix.patch
@@ -0,0 +1,35 @@
+--- kbd-1.08/src/findfile.c.orig 2004-01-29 01:47:40.735190832 +0200
++++ kbd-1.08/src/findfile.c 2004-01-29 02:06:51.703217096 +0200
+@@ -167,6 +167,7 @@
+ FILE *fp;
+ int dl, recdepth;
+ struct decompressor *dc;
++ struct stat tstat;
+
+ if (strlen(fnam) >= sizeof(pathname))
+ return NULL;
+@@ -211,6 +212,7 @@
+
+ /* delete trailing slashes; trailing stars denote recursion */
+ dir = xstrdup(*dp);
++loop:
+ dl = strlen(dir);
+ recdepth = 0;
+ while (dl && dir[dl-1] == '*') {
+@@ -224,8 +226,15 @@
+ }
+
+ fp = findfile_in_dir(fnam, dir, recdepth, suffixes);
+- if (fp)
++ if (fp) {
++ if ((lstat(pathname, &tstat) == 0)
++ && (S_ISDIR(tstat.st_mode) != 0)) {
++ dir = xstrdup(pathname);
++ goto loop;
++ }
++
+ return fp;
++ }
+ }
+
+ return NULL;
diff --git a/sys-apps/kbd/kbd-1.08-r5.ebuild b/sys-apps/kbd/kbd-1.08-r5.ebuild
new file mode 100644
index 000000000000..1ca34de07315
--- /dev/null
+++ b/sys-apps/kbd/kbd-1.08-r5.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kbd/kbd-1.08-r5.ebuild,v 1.1 2004/01/29 00:51:55 azarah Exp $
+
+IUSE="nls"
+
+inherit eutils
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Keyboard and console utilities"
+SRC_URI="ftp://ftp.cwi.nl/pub/aeb/kbd/${P}.tar.gz
+ ftp://ftp.win.tue.nl/pub/home/aeb/linux-local/utils/kbd/${P}.tar.gz"
+HOMEPAGE="http://freshmeat.net/projects/kbd/"
+
+KEYWORDS="x86 amd64 ppc sparc alpha mips hppa arm ia64 ~ppc64"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc nls? ( sys-devel/gettext )"
+PROVIDE="sys-apps/console-tools"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # Fixes makefile so that it uses the CFLAGS from portage (bug #21320).
+ sed -i -e "s:-O2:${CFLAGS}:g" src/Makefile.in
+
+ # Sparc have not yet fixed struct kbd_rate to use 'period' and not 'rate'.
+ epatch ${FILESDIR}/${P}-kbd_repeat.patch
+
+ # Add the --tty switch
+ epatch ${FILESDIR}/${PN}-1.06-othervt.patch
+
+ # Other patches from RH
+ epatch ${FILESDIR}/${P}-nowarn.patch
+ epatch ${FILESDIR}/${P}-terminal.patch
+
+ # Locales do not use DATADIR corretly, and thus install to /share, and
+ # not /usr/share, bug #26384.
+ epatch ${FILESDIR}/${P}-po-install-locations.patch
+
+ # Fixes a problem where loadkeys matches dvorak the dir, and not the
+ # .map inside
+ epatch ${FILESDIR}/${P}-find-map-fix.patch
+}
+
+src_compile() {
+ local myconf=
+
+ # Non-standard configure script; --disable-nls to
+ # disable NLS, nothing to enable it.
+ use nls || myconf="--disable-nls"
+
+ # We should not add the prefix to mandir and datadir
+ ./configure --prefix=/usr \
+ --mandir=/share/man \
+ --datadir=/share \
+ ${myconf} || die
+
+ make || die
+}
+
+src_install() {
+ make \
+ DESTDIR=${D} \
+ DATADIR=${D}/usr/share \
+ MANDIR=${D}/usr/share/man \
+ install || die
+
+ dodir /usr/bin
+ dosym ../../bin/setfont /usr/bin/setfont
+
+ dodoc CHANGES CREDITS COPYING README
+ dodir /usr/share/doc/${PF}/html
+ cp -dR doc/* ${D}/usr/share/doc/${PF}/html/
+}
+