summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/zsnes')
-rw-r--r--games-emulation/zsnes/Manifest12
-rw-r--r--games-emulation/zsnes/zsnes-1.42.ebuild32
2 files changed, 13 insertions, 31 deletions
diff --git a/games-emulation/zsnes/Manifest b/games-emulation/zsnes/Manifest
index a2693199771a..505bb949fb0b 100644
--- a/games-emulation/zsnes/Manifest
+++ b/games-emulation/zsnes/Manifest
@@ -1,17 +1,7 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 3dd1de5123fa4daa46e50fcbb669c59d ChangeLog 5013
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 75fbd4fb677787b91efdb23510980664 zsnes-1.36.ebuild 884
-MD5 40e1ce51bf01c30c804d8cb8d7ee143d zsnes-1.42.ebuild 1983
+MD5 d6f6fd9f99ed1c5bd5eebd8496e418a2 zsnes-1.42.ebuild 1640
MD5 b828464647d2d51e3a08b60e05795f1d files/digest-zsnes-1.36 63
MD5 f06a27f135c6456df1e559f7ca99106c files/1.42-configure.patch 1518
MD5 59162d5cc203f681f780f51b4b9697ee files/digest-zsnes-1.42 64
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFCPn8JArHZZzCEUG0RArPsAKCHqSHO1OlwXdjYHwlnXRPAgLZD6wCcCeYy
-xbKY/vbeuhA11EGK/n40RCg=
-=7N1Y
------END PGP SIGNATURE-----
diff --git a/games-emulation/zsnes/zsnes-1.42.ebuild b/games-emulation/zsnes/zsnes-1.42.ebuild
index a2ba65030074..4a175d21a34c 100644
--- a/games-emulation/zsnes/zsnes-1.42.ebuild
+++ b/games-emulation/zsnes/zsnes-1.42.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/zsnes-1.42.ebuild,v 1.4 2005/03/21 07:59:59 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/zsnes-1.42.ebuild,v 1.5 2005/03/22 05:11:00 vapier Exp $
inherit eutils flag-o-matic games
@@ -13,10 +13,7 @@ SLOT="0"
KEYWORDS="-* ~amd64 x86"
IUSE="opengl png"
-# we need libsdl for headers on amd64, even though we'll technically be using
-# the 32bit sdl from emul-linux-x86-sdl.
-RDEPEND="virtual/libc
- >=media-libs/libsdl-1.2.0
+RDEPEND=">=media-libs/libsdl-1.2.0
>=sys-libs/zlib-1.1
amd64? ( app-emulation/emul-linux-x86-sdl )
opengl? ( virtual/opengl )
@@ -28,20 +25,16 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${PN}_${PV//./_}"
-multilib_check() {
- if use amd64; then
- if has_multilib_profile; then
- ABI_ALLOW="x86"
-
- # And until we get a real multilib portage...
- append-ldflags "-L/emul/linux/x86/usr/lib -L/emul/linux/x86/lib -L/usr/lib32 -L/lib32"
- ABI="x86"
- elif has_m32 ; then
- einfo "multilib detected, adding -m32 to CFLAGS."
- append-flags -m32
- else
- die "zsnes requires multilib support in gcc. please re-emerge gcc with multilib in USE and try again"
- fi
+pkg_setup() {
+ use amd64 || return 0
+ if has_m32 ; then
+ append-flags -m32
+ else
+ eerror "Your compiler seems to be unable to compile 32bit code."
+ eerror "Make sure you compile gcc with:"
+ echo
+ eerror " USE=multilib FEATURES=-sandbox"
+ die "Cannot produce 32bit code"
fi
}
@@ -54,7 +47,6 @@ src_unpack() {
}
src_compile() {
- use amd64 && multilib_check
cd src
egamesconf \
$(use_enable png libpng) \