summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rubytorrent')
-rw-r--r--dev-ruby/rubytorrent/ChangeLog10
-rw-r--r--dev-ruby/rubytorrent/Manifest14
-rw-r--r--dev-ruby/rubytorrent/files/digest-rubytorrent-0.31
-rw-r--r--dev-ruby/rubytorrent/metadata.xml5
-rw-r--r--dev-ruby/rubytorrent/rubytorrent-0.3.ebuild34
5 files changed, 64 insertions, 0 deletions
diff --git a/dev-ruby/rubytorrent/ChangeLog b/dev-ruby/rubytorrent/ChangeLog
new file mode 100644
index 000000000000..58f2086023e6
--- /dev/null
+++ b/dev-ruby/rubytorrent/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/rubytorrent
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubytorrent/ChangeLog,v 1.1 2005/02/15 19:06:36 citizen428 Exp $
+
+*rubytorrent-0.3 (15 Feb 2005)
+
+ 15 Feb 2005; Michael Kohl <citizen428@gentoo.org> +metadata.xml,
+ +rubytorrent-0.3.ebuild:
+ Initial import.
+
diff --git a/dev-ruby/rubytorrent/Manifest b/dev-ruby/rubytorrent/Manifest
new file mode 100644
index 000000000000..25d0e80770b4
--- /dev/null
+++ b/dev-ruby/rubytorrent/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 2e6d2054787664ed29199a2e7a455dba rubytorrent-0.3.ebuild 968
+MD5 5f3b767c850c3d9a62187580d145cf1a ChangeLog 362
+MD5 b522b82d2c47bc548a6607f0f577ab5e metadata.xml 158
+MD5 7058fe999664918d8eac7aa0afd0cb29 files/digest-rubytorrent-0.3 66
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.0 (GNU/Linux)
+
+iD8DBQFCEkhG/UDVUK2NELYRAtFcAJsFK1z5M8Fxb0SSIpfe/zSWoJTfqgCgoCk5
+naeo0Tf/Proohh1zmZBRJOk=
+=OTqY
+-----END PGP SIGNATURE-----
diff --git a/dev-ruby/rubytorrent/files/digest-rubytorrent-0.3 b/dev-ruby/rubytorrent/files/digest-rubytorrent-0.3
new file mode 100644
index 000000000000..1d1cacc7dc76
--- /dev/null
+++ b/dev-ruby/rubytorrent/files/digest-rubytorrent-0.3
@@ -0,0 +1 @@
+MD5 072160777056baf3ef6b97e4af660d6c rubytorrent-0.3.tar.gz 44172
diff --git a/dev-ruby/rubytorrent/metadata.xml b/dev-ruby/rubytorrent/metadata.xml
new file mode 100644
index 000000000000..0040b1162894
--- /dev/null
+++ b/dev-ruby/rubytorrent/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/rubytorrent/rubytorrent-0.3.ebuild b/dev-ruby/rubytorrent/rubytorrent-0.3.ebuild
new file mode 100644
index 000000000000..7c982a4c183c
--- /dev/null
+++ b/dev-ruby/rubytorrent/rubytorrent-0.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubytorrent/rubytorrent-0.3.ebuild,v 1.1 2005/02/15 19:06:36 citizen428 Exp $
+
+DESCRIPTION="A pure-Ruby BitTorrent peer library and toolset"
+HOMEPAGE="http://rubytorrent.rubyforge.org/"
+SRC_URI="http://rubyforge.org/frs/download.php/3017/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="virtual/ruby"
+
+USE_RUBY="ruby18 ruby19"
+
+src_install() {
+ local sitelibdir=`ruby -r rbconfig -e 'puts Config::CONFIG["sitelibdir"]'`
+ insinto "$sitelibdir"
+ doins rubytorrent.rb
+ insinto "$sitelibdir/rubytorrent"
+ doins rubytorrent/*
+ dodoc doc/* README ReleaseNotes.txt
+ docinto examples
+ dodoc dump-metainfo.rb dump-peers.rb make-metainfo.rb \
+ rtpeer-ncurses.rb rtpeer.rb
+}
+
+pkg_postinstall() {
+ einfo
+ einfo "Examples on how to use this package can be found at /usr/share/doc/${PF}/examples/"
+ einfo
+}