summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office')
-rw-r--r--app-office/openoffice/Manifest6
-rw-r--r--app-office/openoffice/openoffice-1.1.0-r4.ebuild26
-rw-r--r--app-office/openoffice/openoffice-1.1.0-r5.ebuild26
-rw-r--r--app-office/openoffice/openoffice-1.1.1-r1.ebuild26
4 files changed, 42 insertions, 42 deletions
diff --git a/app-office/openoffice/Manifest b/app-office/openoffice/Manifest
index 9b7d7f4afcf9..532cf84338e8 100644
--- a/app-office/openoffice/Manifest
+++ b/app-office/openoffice/Manifest
@@ -1,7 +1,7 @@
-MD5 2b9bc273541bfa9e8fa7f6965b5792a6 openoffice-1.1.0-r5.ebuild 16003
+MD5 eaec6c07e6adbe6357128fb57f285d5d openoffice-1.1.0-r5.ebuild 16013
MD5 d6aa449f5f48ee14fe777545fd8910cc openoffice-1.0.3-r2.ebuild 21530
-MD5 0f272c1acaed87b12f6ef138ca5ee9b4 openoffice-1.1.1-r1.ebuild 16366
-MD5 d264637d4e591cd8f1c032e32598468f openoffice-1.1.0-r4.ebuild 20392
+MD5 2fb2c46fd3625ee353a347adc815d6d1 openoffice-1.1.1-r1.ebuild 16376
+MD5 0d4e399ca510dcbac9772ca214530b25 openoffice-1.1.0-r4.ebuild 20394
MD5 7e58a79d274f67b87697462d245c38e8 ChangeLog 16914
MD5 e3ec4a70395943b59adad7fc4f0538d7 metadata.xml 461
MD5 b1ec8fd75e9b93ccf4a4f0c926de5199 files/digest-openoffice-1.0.3-r2 330
diff --git a/app-office/openoffice/openoffice-1.1.0-r4.ebuild b/app-office/openoffice/openoffice-1.1.0-r4.ebuild
index 7aa01a2e121a..c16e29565f68 100644
--- a/app-office/openoffice/openoffice-1.1.0-r4.ebuild
+++ b/app-office/openoffice/openoffice-1.1.0-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-1.1.0-r4.ebuild,v 1.3 2004/05/05 10:41:56 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-1.1.0-r4.ebuild,v 1.4 2004/05/07 14:40:14 suka Exp $
# IMPORTANT: This is extremely alpha!!!
@@ -26,19 +26,8 @@
# Get support going for installing a custom language pack. Also
# need to be able to install more than one language pack.
-inherit flag-o-matic eutils
-# Compile problems with these ...
-filter-flags "-funroll-loops"
-filter-flags "-fomit-frame-pointer"
-filter-flags "-fprefetch-loop-arrays"
-filter-flags "-fno-default-inline"
-append-flags "-fno-strict-aliasing"
-replace-flags "-O3" "-O2"
+inherit flag-o-matic eutils gcc
-# Enable Bytecode Interpreter for freetype ...
-append-flags "-DTT_CONFIG_OPTION_BYTECODE_INTERPRETER"
-
-inherit gcc
# We want gcc3 if possible!!!!
export WANT_GCC_3="yes"
@@ -299,6 +288,17 @@ src_unpack() {
# einfo "Removing crashrep from the installed set"
# sed -i -e "s,\(crashrep \),," ${S}/instsetoo/prj/build.lst
+ # Compile problems with these ...
+ filter-flags "-funroll-loops"
+ filter-flags "-fomit-frame-pointer"
+ filter-flags "-fprefetch-loop-arrays"
+ filter-flags "-fno-default-inline"
+ append-flags "-fno-strict-aliasing"
+ replace-flags "-O3" "-O2"
+
+ # Enable Bytecode Interpreter for freetype ...
+ append-flags "-DTT_CONFIG_OPTION_BYTECODE_INTERPRETER"
+
if [ "$(gcc-version)" == "3.2" ]; then
einfo "You use a buggy gcc, so replacing -march=pentium4 with -march=pentium3"
replace-flags "-march=pentium4" "-march=pentium3 -mcpu=pentium4"
diff --git a/app-office/openoffice/openoffice-1.1.0-r5.ebuild b/app-office/openoffice/openoffice-1.1.0-r5.ebuild
index 25669ad0377d..2abf8b34addb 100644
--- a/app-office/openoffice/openoffice-1.1.0-r5.ebuild
+++ b/app-office/openoffice/openoffice-1.1.0-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-1.1.0-r5.ebuild,v 1.3 2004/05/05 10:41:56 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-1.1.0-r5.ebuild,v 1.4 2004/05/07 14:40:14 suka Exp $
# IMPORTANT: This is extremely alpha!!!
@@ -28,18 +28,6 @@
inherit flag-o-matic eutils gcc
-# Compile problems with these ...
-filter-flags "-funroll-loops"
-filter-flags "-fomit-frame-pointer"
-filter-flags "-fprefetch-loop-arrays"
-filter-flags "-fno-default-inline"
-append-flags "-fno-strict-aliasing"
-replace-flags "-O3" "-O2"
-replace-flags "-Os" "-O2"
-
-# Enable Bytecode Interpreter for freetype ...
-append-flags "-DTT_CONFIG_OPTION_BYTECODE_INTERPRETER"
-
# We want gcc3 if possible!!!!
export WANT_GCC_3="yes"
@@ -276,6 +264,18 @@ src_unpack() {
#Security fix
epatch ${FILESDIR}/${PV}/neon.patch
+ # Compile problems with these ...
+ filter-flags "-funroll-loops"
+ filter-flags "-fomit-frame-pointer"
+ filter-flags "-fprefetch-loop-arrays"
+ filter-flags "-fno-default-inline"
+ append-flags "-fno-strict-aliasing"
+ replace-flags "-O3" "-O2"
+ replace-flags "-Os" "-O2"
+
+ # Enable Bytecode Interpreter for freetype ...
+ append-flags "-DTT_CONFIG_OPTION_BYTECODE_INTERPRETER"
+
if [ "$(gcc-version)" == "3.2" ]; then
einfo "You use a buggy gcc, so replacing -march=pentium4 with -march=pentium3"
replace-flags "-march=pentium4" "-march=pentium3 -mcpu=pentium4"
diff --git a/app-office/openoffice/openoffice-1.1.1-r1.ebuild b/app-office/openoffice/openoffice-1.1.1-r1.ebuild
index ce1a2f65a8fa..d3af721ea529 100644
--- a/app-office/openoffice/openoffice-1.1.1-r1.ebuild
+++ b/app-office/openoffice/openoffice-1.1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-1.1.1-r1.ebuild,v 1.3 2004/05/05 10:41:56 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-1.1.1-r1.ebuild,v 1.4 2004/05/07 14:40:14 suka Exp $
# IMPORTANT: This is extremely alpha!!!
@@ -28,18 +28,6 @@
inherit flag-o-matic eutils gcc
-# Compile problems with these ...
-filter-flags "-funroll-loops"
-filter-flags "-fomit-frame-pointer"
-filter-flags "-fprefetch-loop-arrays"
-filter-flags "-fno-default-inline"
-append-flags "-fno-strict-aliasing"
-replace-flags "-O3" "-O2"
-replace-flags "-Os" "-O2"
-
-# Enable Bytecode Interpreter for freetype ...
-append-flags "-DTT_CONFIG_OPTION_BYTECODE_INTERPRETER"
-
# We want gcc3 if possible!!!!
export WANT_GCC_3="yes"
@@ -278,6 +266,18 @@ src_unpack() {
#Security fix
epatch ${FILESDIR}/${PV}/neon.patch
+ # Compile problems with these ...
+ filter-flags "-funroll-loops"
+ filter-flags "-fomit-frame-pointer"
+ filter-flags "-fprefetch-loop-arrays"
+ filter-flags "-fno-default-inline"
+ append-flags "-fno-strict-aliasing"
+ replace-flags "-O3" "-O2"
+ replace-flags "-Os" "-O2"
+
+ # Enable Bytecode Interpreter for freetype ...
+ append-flags "-DTT_CONFIG_OPTION_BYTECODE_INTERPRETER"
+
if [ "$(gcc-version)" == "3.2" ]; then
einfo "You use a buggy gcc, so replacing -march=pentium4 with -march=pentium3"
replace-flags "-march=pentium4" "-march=pentium3 -mcpu=pentium4"