summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/gvim/gvim-6.1-r7.ebuild')
-rw-r--r--app-editors/gvim/gvim-6.1-r7.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-editors/gvim/gvim-6.1-r7.ebuild b/app-editors/gvim/gvim-6.1-r7.ebuild
new file mode 100644
index 000000000000..d6dcb6d1e71c
--- /dev/null
+++ b/app-editors/gvim/gvim-6.1-r7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-6.1-r7.ebuild,v 1.1 2003/03/15 00:52:12 rphillips Exp $
+
+VIMPATCH="390"
+
+EXCLUDE_PATCH="093 100 119 121 126 138 152 164 258 \
+304 314 322 334 335 340 346 352 353 354 355 356 374"
+
+use nls || EXCLUDE_PATCH="${EXCLUDE_PATCH} 295 301"
+
+inherit vim
+
+DESCRIPTION="Graphical Vim"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+DEPEND="dev-util/cscope
+ >=sys-libs/ncurses-5.2-r2
+ app-editors/vim-core
+ x11-base/xfree
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ gnome? ( gnome-base/gnome-libs )
+ gtk? ( =x11-libs/gtk+-1.2* )
+ gtk2? ( >=x11-libs/gtk+-2.1
+ x11-libs/xft )
+ perl? ( dev-lang/perl )
+ python? ( dev-lang/python )
+ ruby? ( >=dev-lang/ruby-1.6.4 )"
+# tcltk? ( dev-lang/tcl )"
+# It appears that the tclinterp stuff in Vim is broken right now (at
+# least on Linux... it works on BSD). When you --enable-tclinterp
+# flag, then the following command never returns:
+#
+# VIMINIT='let OS = system("uname -s")' vim
+#
+# Please don't re-enable the tclinterp flag without verifying first
+# that the above works. Thanks. (08 Sep 2001 agriffis)