summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/bootsplash/ChangeLog9
-rw-r--r--media-gfx/bootsplash/Manifest4
-rw-r--r--media-gfx/bootsplash/bootsplash-0.6-r9.ebuild185
-rw-r--r--media-gfx/bootsplash/files/digest-bootsplash-0.6-r91
4 files changed, 197 insertions, 2 deletions
diff --git a/media-gfx/bootsplash/ChangeLog b/media-gfx/bootsplash/ChangeLog
index 69cf46578fbd..b5d1741d0c43 100644
--- a/media-gfx/bootsplash/ChangeLog
+++ b/media-gfx/bootsplash/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-gfx/bootsplash
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/bootsplash/ChangeLog,v 1.22 2004/02/18 20:24:40 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/bootsplash/ChangeLog,v 1.23 2004/02/23 08:44:27 seemant Exp $
+
+*bootsplash-0.6-r9 (23 Feb 2004)
+
+ 23 Feb 2004; Seemant Kulleen <seemant@gentoo.org> bootsplash-0.6-r9.ebuild:
+ New bootsplash piccies for the 2004.0 livecd. Also, clean up of the syntax --
+ except, for the eval line -- doesn't seem to have any purpose in this ebuild,
+ but not sure. Spock or TaD need to weigh in on that.
*bootsplash-0.6-r8 (18 Feb 2004)
diff --git a/media-gfx/bootsplash/Manifest b/media-gfx/bootsplash/Manifest
index 574474fc8271..62a5d1b508f2 100644
--- a/media-gfx/bootsplash/Manifest
+++ b/media-gfx/bootsplash/Manifest
@@ -3,8 +3,9 @@ MD5 e8529ec584ba0c32dcf21ae81d9716a0 bootsplash-0.6-r8.ebuild 5170
MD5 000b763c35a5c1604070379a0c3a2a44 bootsplash-0.6-r3.ebuild 3437
MD5 c43419bbf9461e0d81c84328005977ac bootsplash-0.6-r5.ebuild 5391
MD5 fbd2d9894a5ecd9f94a43d7f9831e9ac bootsplash-0.6-r7.ebuild 5169
+MD5 bc17a454fc8e42f87d415dc23238c996 bootsplash-0.6-r9.ebuild 5017
MD5 cb4bad8e460384e14ecd02984dea1d04 bootsplash-0.6-r4.ebuild 4961
-MD5 ff86c89e62ebb1d3e7f0b29f41ee72d5 ChangeLog 3984
+MD5 0ebcdafec758b92899f915980e091ae4 ChangeLog 4314
MD5 d94d306da3804e41296e1bf04c7c9cae metadata.xml 255
MD5 250d9fd431815e7ee0ebdad859d9796a files/digest-bootsplash-0.6-r3 70
MD5 eacb36a273e1eccd1f98e95d0a3b2646 files/digest-bootsplash-0.6-r4 70
@@ -12,3 +13,4 @@ MD5 b691cde294a34c424af911aca0796593 files/digest-bootsplash-0.6-r5 70
MD5 9dfc24b59ada6a41dabaf698c9a2edf5 files/digest-bootsplash-0.6-r6 70
MD5 f0780470a69548577745c4a344633a72 files/digest-bootsplash-0.6-r7 70
MD5 6a993c12a7aad0735a4783e1f7c2c968 files/digest-bootsplash-0.6-r8 70
+MD5 80d57c4a370abbf5613da61aabfca6a7 files/digest-bootsplash-0.6-r9 70
diff --git a/media-gfx/bootsplash/bootsplash-0.6-r9.ebuild b/media-gfx/bootsplash/bootsplash-0.6-r9.ebuild
new file mode 100644
index 000000000000..724f47a6b3b9
--- /dev/null
+++ b/media-gfx/bootsplash/bootsplash-0.6-r9.ebuild
@@ -0,0 +1,185 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/bootsplash/bootsplash-0.6-r9.ebuild,v 1.1 2004/02/23 08:44:27 seemant Exp $
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="Graphical backgrounds for frame buffer consoles"
+HOMEPAGE="http://www.bootsplash.org/ http://linux.tkdack.com/"
+SRC_URI="http://dev.gentoo.org/~seemant/extras/${PF}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc"
+
+DEPEND=">=media-libs/freetype-2
+ media-libs/libmng"
+
+src_compile() {
+ # compile utils
+ # the util builds but the rc scripts have not been modified
+ # animated boot up require patches to the baselayout package
+ cd ${S}/utils
+
+ emake -C fbmngplay || die
+ emake -C fbtruetype || die
+ emake -C splashutils || die
+
+ cd ${S}
+}
+
+src_install() {
+ # Splash utilities
+ exeinto /sbin
+ doexe utils/fbmngplay/fbmngplay{,.static}
+ doexe utils/fbtruetype/fbtruetype{,.static}
+ newexe utils/splashutils/splash splash.bin
+ doexe misc/splash
+ doexe utils/splashutils/{fbresolution,getkey,progress}
+
+ dodir /etc/${PN}
+ cp -pR themes/* ${D}/etc/${PN}
+
+ # link default config for boot images if not already set
+ if [ ! -e ${ROOT}/etc/bootsplash/default ]; then
+ use livecd \
+ && dosym ./livecd-2004.0 /etc/bootsplash/default \
+ || dosym ./gentoo /etc/bootsplash/default
+ fi
+
+ exeinto /etc/init.d
+ doexe misc/bootsplash
+
+ insinto /etc/conf.d
+ doins misc/bootsplash.conf
+
+ insinto /usr/share/${PN}
+ doins kernel/*.bz2 misc/grub.conf.sample
+
+ sed -i "s:${PN}:${PF}:g" bootsplash_patch
+ into /
+ dosbin bootsplash_patch
+ fperms 0754 /sbin/bootsplash_patch
+}
+
+pkg_postinst() {
+ # Has to be done here so that the initrd images are created properly
+ if [ "${ROOT}" = "/" ]
+ then
+ for SIZE in 800x600 1024x768 1280x1024 1600x1200
+ do
+ /sbin/splash -s -f \
+ /etc/bootsplash/gentoo/config/bootsplash-${SIZE}.cfg \
+ > /usr/share/${PN}/initrd-${SIZE}
+ done
+ fi
+
+ echo ""
+ einfo "Execute \"bootsplash_patch\" to have your kernel sources in"
+ einfo "/usr/src/linux patched with the Framebuffer Bootsplash patches."
+ einfo
+ einfo "You can also use:"
+ einfo " bootsplash_patch /path/to/your/custom/kernel/"
+ einfo "to patch your custom kernel sources."
+ echo ""
+ ewarn "If you have already patched the kernel then you only need to copy"
+ ewarn "an initrd from /usr/share/${PN} to /boot"
+ echo ""
+ einfo "Run:"
+ einfo " rc-update add bootsplash default"
+ einfo "to change the console images after startup"
+ echo ""
+ einfo "Please note that in case /usr is a separate partition"
+ einfo "you'll need to use the statically linked versions of Bootplash"
+ einfo 'utilities (fbmngplay.static, fbtruetype.static) during boot-time.'
+ echo ""
+}
+
+pkg_config() {
+
+ if [ "${LINUX}" == "" ]; then
+ LINUX='/usr/src/linux'
+ fi
+
+ eval `sed -n -e 's/^\([A-Z]*\) = \([0-9]*\)$/\1=\2/p' -e 's/^\([A-Z]*\) = \(-[-a-z0-9]*\)$/\1=\2/p' ${LINUX}/Makefile`
+
+ if [ -z "$VERSION" -o -z "$PATCHLEVEL" -o -z "$SUBLEVEL" ]
+ then
+ die "Unable to determine kernel version in ${LINUX}"
+ fi
+
+ KB="${VERSION}.${PATCHLEVEL}"
+ KV_MINOR="${SUBLEVEL}"
+
+ ewarn
+ ewarn "Patching the kernel (branch: ${KB}) in ${LINUX} ..."
+ ewarn
+
+ cd ${ROOT}/${LINUX}
+
+ if [ "${KB}" == "2.4" ]; then
+
+ if [ -f drivers/video/fbcon-splash.c ]; then
+ eerror
+ eerror "It appears your kernel has already been patched."
+ eerror
+ exit 1
+ fi
+
+ if [ ${KV_MINOR} -ge 22 ]; then
+ bzip2 -dc \
+ ${ROOT}/usr/share/${PN}/${PN}-3.0.7-2.4.22-vanilla.diff.bz2 \
+ | patch -p1 || die
+ else
+ bzip2 -dc \
+ ${ROOT}/usr/share/${PN}/${PN}-3.0.7-2.4.20-vanilla.diff.bz2 \
+ | patch -p1 || die
+ fi
+
+ elif [ "${KB}" == "2.6" ]; then
+
+ if [ -d drivers/video/bootsplash ]; then
+ eerror
+ eerror "It appears your kernel has already been patched."
+ eerror
+ exit 1
+ fi
+
+ if [ ${KV_MINOR} -ge 3 ]; then
+ bzip2 -dc \
+ ${ROOT}/usr/share/${PN}/${PN}-3.1.3-2.6.3-r2.patch.bz2 \
+ | patch -p1 || die
+ else
+ bzip2 -dc \
+ ${ROOT}/usr/share/${PN}/${PN}-3.1.3-2.6.0-test9.diff.bz2 \
+ | patch -p1 || die
+ fi
+ else
+ die "Sorry, this kernel branch is not supported."
+ fi
+
+ ewarn
+ ewarn " ... complete."
+ einfo
+ einfo "Your kernel has been patched, rebuild with the following options"
+ einfo "enabled (do not build them as modules!):"
+ einfo " Block Devices ->"
+ einfo " [*] RAM disk support"
+ einfo " [*] Loopback device support"
+ einfo " [*] Initial RAM disk (initrd) support"
+ einfo
+ einfo " Console Drivers ->"
+ einfo " [*] Video mode selection support"
+ einfo " Frame-buffer support ->"
+ einfo " [*] Support for frame buffer devices"
+ einfo " [*] VESA VGA graphics console"
+ einfo " [*] Use splash screen instead of boot logo"
+ einfo
+ einfo "Copy an initrd from /usr/share/${PN} to /boot"
+ einfo
+ einfo "Look at \"/usr/share/${PN}/grub.conf.sample\" for an example"
+ einfo "grub.conf file with the appropriate changes to enable the"
+ einfo "framebuffer boot screens"
+ einfo
+ einfo "Ensure you make the appropriate changes to your grub.conf"
+ einfo
+}
diff --git a/media-gfx/bootsplash/files/digest-bootsplash-0.6-r9 b/media-gfx/bootsplash/files/digest-bootsplash-0.6-r9
new file mode 100644
index 000000000000..ba9ec158a4e2
--- /dev/null
+++ b/media-gfx/bootsplash/files/digest-bootsplash-0.6-r9
@@ -0,0 +1 @@
+MD5 24997333053f1e4671596e00f012ec19 bootsplash-0.6-r9.tar.bz2 519855