summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Leitch <port001@gentoo.org>2003-11-20 23:29:53 +0000
committerIan Leitch <port001@gentoo.org>2003-11-20 23:29:53 +0000
commit9abbd1080f139b7df0d24786d0ecd2aa7f408c5e (patch)
treea6421342b40bb70a829d8dd56ad89d112e1fe9cb /x11-misc/xhkeys
parentMoved from app-misc to x11-misc, metadata.xml created. (diff)
downloadhistorical-9abbd1080f139b7df0d24786d0ecd2aa7f408c5e.tar.gz
historical-9abbd1080f139b7df0d24786d0ecd2aa7f408c5e.tar.bz2
historical-9abbd1080f139b7df0d24786d0ecd2aa7f408c5e.zip
Moved from app-misc to x11-misc, metadata.xml created.
Diffstat (limited to 'x11-misc/xhkeys')
-rw-r--r--x11-misc/xhkeys/Manifest6
-rw-r--r--x11-misc/xhkeys/files/digest-xhkeys-1.0.01
-rw-r--r--x11-misc/xhkeys/files/xhkeys16
-rw-r--r--x11-misc/xhkeys/metadata.xml5
-rw-r--r--x11-misc/xhkeys/xhkeys-1.0.0.ebuild28
5 files changed, 53 insertions, 3 deletions
diff --git a/x11-misc/xhkeys/Manifest b/x11-misc/xhkeys/Manifest
index 60188461d9a2..45a9a244352c 100644
--- a/x11-misc/xhkeys/Manifest
+++ b/x11-misc/xhkeys/Manifest
@@ -1,5 +1,5 @@
-MD5 e6eada5da2574c70657969148528df5a xhkeys-1.0.0.ebuild 698
-MD5 044ba4de4414ffdebb7b2761242bd9d2 ChangeLog 330
+MD5 736aec57a618e8e2940c9d53822097c2 xhkeys-1.0.0.ebuild 699
+MD5 950216d72440e7df8bdee97ebf8e805b ChangeLog 486
MD5 fe402b096905cae8dcb4a503d3a838ac metadata.xml 173
MD5 fe49e0dbeae105106e62674db274f26e files/digest-xhkeys-1.0.0 63
-MD5 ce2ba0d27d4eadf07aa6b794e3e25e33 files/xhkeys 456
+MD5 263814a99f913e47d022dffaa9e3366d files/xhkeys 459
diff --git a/x11-misc/xhkeys/files/digest-xhkeys-1.0.0 b/x11-misc/xhkeys/files/digest-xhkeys-1.0.0
new file mode 100644
index 000000000000..89da43cf225e
--- /dev/null
+++ b/x11-misc/xhkeys/files/digest-xhkeys-1.0.0
@@ -0,0 +1 @@
+MD5 aa5fbb575716bb81208924a0e72d277c xhkeys-1.0.0.tar.gz 52264
diff --git a/x11-misc/xhkeys/files/xhkeys b/x11-misc/xhkeys/files/xhkeys
new file mode 100644
index 000000000000..d0c5d6199400
--- /dev/null
+++ b/x11-misc/xhkeys/files/xhkeys
@@ -0,0 +1,16 @@
+#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xhkeys/files/xhkeys,v 1.1 2003/11/20 23:29:49 port001 Exp $
+
+start() {
+ ebegin "Starting xhkeys"
+ start-stop-daemon --start --quiet --exec /usr/bin/xhkeys
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping xhkeys"
+ start-stop-daemon --stop --quiet --exec /usr/bin/xhkeys
+ eend $?
+}
diff --git a/x11-misc/xhkeys/metadata.xml b/x11-misc/xhkeys/metadata.xml
new file mode 100644
index 000000000000..2518313f5241
--- /dev/null
+++ b/x11-misc/xhkeys/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+</pkgmetadata>
diff --git a/x11-misc/xhkeys/xhkeys-1.0.0.ebuild b/x11-misc/xhkeys/xhkeys-1.0.0.ebuild
new file mode 100644
index 000000000000..c27b665cfbd5
--- /dev/null
+++ b/x11-misc/xhkeys/xhkeys-1.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xhkeys/xhkeys-1.0.0.ebuild,v 1.1 2003/11/20 23:29:49 port001 Exp $
+
+DESCRIPTION="assign particular actions to any key or key combination"
+HOMEPAGE="http://www.geocities.com/wmalms/"
+SRC_URI="http://www.geocities.com/wmalms/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="x11-base/xfree"
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ dobin xhkeys xhkconf
+ dodoc README VERSION
+}