summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Gavin <pete@gentoo.org>2001-04-30 02:46:21 +0000
committerPeter Gavin <pete@gentoo.org>2001-04-30 02:46:21 +0000
commit611610d18918f2d245c963001aba937bc9afdc69 (patch)
treeaf49c8e8b6e0a40b112c4beaf96da34fee4d1f28 /x11-libs
parentFixed header issue (diff)
downloadhistorical-611610d18918f2d245c963001aba937bc9afdc69.tar.gz
historical-611610d18918f2d245c963001aba937bc9afdc69.tar.bz2
historical-611610d18918f2d245c963001aba937bc9afdc69.zip
heh... added a missing '\'
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtk+/gtk+-1.2.10-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/x11-libs/gtk+/gtk+-1.2.10-r1.ebuild b/x11-libs/gtk+/gtk+-1.2.10-r1.ebuild
new file mode 100644
index 000000000000..38e847f24f33
--- /dev/null
+++ b/x11-libs/gtk+/gtk+-1.2.10-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-1.2.10-r1.ebuild,v 1.1 2001/04/30 02:46:21 pete Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="gtk"
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/v1.2/${A}
+ ftp://ftp.gnome.org/pub/GNOME/stable/sources/gtk+/${A}
+ http://ftp.gnome.org/pub/GNOME/stable/sources/gtk+/${A}"
+HOMEPAGE="http://www.gtk.org/"
+
+DEPEND="virtual/glibc
+ >=dev-libs/glib-1.2.10
+ >=x11-base/xfree-4.0.1"
+
+src_compile() {
+ local myconf
+
+ if [ "${DEBUG}" ]
+ then
+ myconf="--enable-debug=yes"
+ else
+ myconf="--enable-debug=no"
+ fi
+
+ try ./configure --host=${CHOST} --prefix=/usr/X11R6 ${myconf} \
+ --infodir=/usr/X11R6/share/info --mandir=/usr/X11R6/share/man --sysconfdir=/etc/X11 \
+ --with-xinput=xfree --with-x
+ try make
+}
+
+src_install() {
+ try make install DESTDIR=${D}
+
+ preplib /usr/X11R6
+
+ dodoc AUTHORS COPYING ChangeLog* HACKING
+ dodoc NEWS* README* TODO
+ docinto docs
+ cd docs
+ dodoc *.txt *.gif text/*
+ cd html
+ docinto html
+ dodoc *.html *.gif
+
+ #install nice, clean-looking default gtk+ style
+ insinto /etc/X11/gtk
+ doins ${FILESDIR}/gtkrc
+}
+
+
+
+