summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-11-03 16:31:05 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-11-03 16:31:05 +0000
commit6e9827de00edc0bb0a6fe077b16b9694ac2726f5 (patch)
treea0314490ab642a367b0f8019fb62003898871e78 /kde-base/dolphin
parentKeyword ~ppc64 wrt #337385 (diff)
downloadhistorical-6e9827de00edc0bb0a6fe077b16b9694ac2726f5.tar.gz
historical-6e9827de00edc0bb0a6fe077b16b9694ac2726f5.tar.bz2
historical-6e9827de00edc0bb0a6fe077b16b9694ac2726f5.zip
KDE SC 4.5.3 Version bump
Package-Manager: portage-2.2.0_alpha3/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/dolphin')
-rw-r--r--kde-base/dolphin/ChangeLog7
-rw-r--r--kde-base/dolphin/dolphin-4.5.3.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/kde-base/dolphin/ChangeLog b/kde-base/dolphin/ChangeLog
index 2ea94e0430dd..0d15efc06682 100644
--- a/kde-base/dolphin/ChangeLog
+++ b/kde-base/dolphin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/dolphin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.86 2010/10/06 09:17:15 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.87 2010/11/03 16:30:29 scarabeus Exp $
+
+*dolphin-4.5.3 (03 Nov 2010)
+
+ 03 Nov 2010; Tomáš Chvátal <scarabeus@gentoo.org> +dolphin-4.5.3.ebuild:
+ Version bump
*dolphin-4.5.2 (05 Oct 2010)
diff --git a/kde-base/dolphin/dolphin-4.5.3.ebuild b/kde-base/dolphin/dolphin-4.5.3.ebuild
new file mode 100644
index 000000000000..7536028ef625
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.5.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.5.3.ebuild,v 1.1 2010/11/03 16:30:29 scarabeus Exp $
+
+EAPI="3"
+
+KDE_HANDBOOK="optional"
+KMNAME="kdebase-apps"
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug semantic-desktop thumbnail"
+
+DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ $(add_kdebase_dep libkonq)
+ semantic-desktop? ( >=dev-libs/shared-desktop-ontologies-0.2 )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kfind)
+"
+PDEPEND="
+ thumbnail? (
+ || (
+ $(add_kdebase_dep ffmpegthumbs)
+ $(add_kdebase_dep mplayerthumbs)
+ )
+ )
+"
+
+KMLOADLIBS="libkonq"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ )
+
+ kde4-meta_src_configure
+}