summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2003-06-16 00:33:57 +0000
committerMichael Cummings <mcummings@gentoo.org>2003-06-16 00:33:57 +0000
commit758bbf1d1b130376a3ad3902c8b8b621d15bf6d0 (patch)
tree273e585fa56acc9dd2d2d13020851d4c7bcc4009 /dev-perl/PDL
parentVersion bump from CPAN. May help bug 22456 (diff)
downloadhistorical-758bbf1d1b130376a3ad3902c8b8b621d15bf6d0.tar.gz
historical-758bbf1d1b130376a3ad3902c8b8b621d15bf6d0.tar.bz2
historical-758bbf1d1b130376a3ad3902c8b8b621d15bf6d0.zip
Version bump from CPAN. May help bug 22456
Diffstat (limited to 'dev-perl/PDL')
-rw-r--r--dev-perl/PDL/Manifest4
-rw-r--r--dev-perl/PDL/PDL-2.4.0.ebuild60
-rw-r--r--dev-perl/PDL/files/digest-PDL-2.4.01
3 files changed, 63 insertions, 2 deletions
diff --git a/dev-perl/PDL/Manifest b/dev-perl/PDL/Manifest
index fdcd30b05be9..1092dd1b52f3 100644
--- a/dev-perl/PDL/Manifest
+++ b/dev-perl/PDL/Manifest
@@ -1,8 +1,8 @@
-MD5 a5182cbe3f4a0edfacc39c62fa3b0c8e ChangeLog 1264
+MD5 cb3b02ea3315a203d68838f025405979 ChangeLog 1410
MD5 005c1c2b14eba50d5029692b7e83e9d0 PDL-2.3.2-r1.ebuild 1429
MD5 b0e751c7b8fad7c5b2f9db47031b1230 PDL-2.3.2-r2.ebuild 1428
MD5 3c432b02aa1e6bb7cc5baefcd6c7c52d PDL-2.3.4.ebuild 1509
-MD5 6ff6685108c69e9751c8affdd2b6d344 PDL-2.4.0.ebuild 1415
+MD5 ec96d2008a302fdf81b5d18652a6ecad PDL-2.4.0.ebuild 1510
MD5 6227c564933ab56193b3e40c1b9849a9 files/digest-PDL-2.3.2-r1 62
MD5 6227c564933ab56193b3e40c1b9849a9 files/digest-PDL-2.3.2-r2 62
MD5 62cbe79e2c7c354d5c165b63c571cc13 files/perldl.conf 2716
diff --git a/dev-perl/PDL/PDL-2.4.0.ebuild b/dev-perl/PDL/PDL-2.4.0.ebuild
new file mode 100644
index 000000000000..f633d8f6441d
--- /dev/null
+++ b/dev-perl/PDL/PDL-2.4.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/PDL-2.4.0.ebuild,v 1.1 2003/06/16 00:33:54 mcummings Exp $
+
+IUSE="opengl"
+
+inherit perl-module
+
+S=${WORKDIR}/${P}
+DESCRIPTION="PDL Perl Module"
+SRC_URI="http://cpan.valueclick.com/modules/by-module/PDL/${P}.tar.gz"
+HOMEPAGE="http://cpan.valueclick.com/modules/by-module/PDL/${P}.readme"
+
+SLOT="0"
+LICENSE="Artistic as-is"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+DEPEND="${DEPEND}
+ >=sys-libs/ncurses-5.2
+ dev-perl/Filter
+ dev-perl/File-Spec
+ dev-perl/Inline
+ >=dev-perl/ExtUtils-F77-1.13
+ dev-perl/Text-Balanced
+ opengl? ( virtual/opengl virtual/glu )"
+
+mydoc="DEPNDENCIES DEVELOPMENT MANIFEST* COPYING Release_Notes TODO"
+
+src_unpack() {
+
+ unpack ${A}
+
+ #open gl does not work at the moment
+ if [ "`use opengl`" ]
+ then
+ echo "OpenGL support is current disabled due to build issues"
+ sed -e "s:WITH_3D => undef:WITH_3D => 0:" \
+ ${FILESDIR}/perldl.conf > ${S}/perldl.conf
+ else
+ sed -e "s:WITH_3D => undef:WITH_3D => 0:" \
+ ${FILESDIR}/perldl.conf > ${S}/perldl.conf
+ fi
+}
+
+src_install () {
+
+ perl-module_src_install
+
+ mv ${D}/usr/lib/perl5/site_perl/5.6.0/${CHOST%%-*}-linux/PDL/HtmlDocs \
+ ${D}/usr/doc/${P}/html
+
+ mydir=${D}/usr/doc/${P}/html/PDL
+
+ for i in ${mydir}/* ${mydir}/IO/* ${mydir}/Fit/* ${mydir}/Pod/* ${mydir}/Graphics/*
+ do
+ dosed ${i/${D}}
+ done
+
+ dosed /usr/lib/perl5/site_perl/5.6.0/${CHOST%%-*}-linux/PDL/pdldoc.db
+}
diff --git a/dev-perl/PDL/files/digest-PDL-2.4.0 b/dev-perl/PDL/files/digest-PDL-2.4.0
new file mode 100644
index 000000000000..0947c21e7923
--- /dev/null
+++ b/dev-perl/PDL/files/digest-PDL-2.4.0
@@ -0,0 +1 @@
+MD5 4804aedbfdf6eb2574a61ca0134386ae PDL-2.4.0.tar.gz 1758829