summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2010-11-05 20:03:27 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2010-11-05 20:03:27 +0000
commit629e02e6fc0c9e12005dc07b29ea408cd0db076f (patch)
treee1213c81900159f539ccc0ea1276e423bf25ab26 /dev-lua
parentPin glib/gtk+ to slot 2. (diff)
downloadhistorical-629e02e6fc0c9e12005dc07b29ea408cd0db076f.tar.gz
historical-629e02e6fc0c9e12005dc07b29ea408cd0db076f.tar.bz2
historical-629e02e6fc0c9e12005dc07b29ea408cd0db076f.zip
Moved from dev-libs to dev-lua. Added myself to metadata.xml
Package-Manager: portage-2.2.0_alpha3/cvs/Linux x86_64
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luaevent-prosody/ChangeLog23
-rw-r--r--dev-lua/luaevent-prosody/Manifest4
-rw-r--r--dev-lua/luaevent-prosody/luaevent-prosody-0.1.1.ebuild48
-rw-r--r--dev-lua/luaevent-prosody/metadata.xml11
4 files changed, 86 insertions, 0 deletions
diff --git a/dev-lua/luaevent-prosody/ChangeLog b/dev-lua/luaevent-prosody/ChangeLog
new file mode 100644
index 000000000000..96a6f934ac28
--- /dev/null
+++ b/dev-lua/luaevent-prosody/ChangeLog
@@ -0,0 +1,23 @@
+# ChangeLog for dev-lua/luaevent-prosody
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/luaevent-prosody/ChangeLog,v 1.1 2010/11/05 20:03:27 rafaelmartins Exp $
+
+ 05 Nov 2010; Rafael G. Martins <rafaelmartins@gentoo.org>
+ +luaevent-prosody-0.1.1.ebuild, +metadata.xml:
+ Moved from dev-libs to dev-lua. Added myself to metadata.xml
+
+ 11 Aug 2010; Markos Chandras <hwoarang@gentoo.org>
+ luaevent-prosody-0.1.1.ebuild:
+ Respect CC,CFLAGS,LDFLAGS. Bug #331849. Thanks to Diego E. 'Flameeyes'
+ Pettenò <flameeyes@gentoo.org> for reporting
+
+ 13 Jul 2010; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ metadata.xml:
+ Added missing herd tag to metadata.xml
+
+*luaevent-prosody-0.1.1 (12 Jul 2010)
+
+ 12 Jul 2010; Dirkjan Ochtman <djc@gentoo.org>
+ +luaevent-prosody-0.1.1.ebuild, +metadata.xml:
+ Initial version (for net-im/prosody-0.7).
+
diff --git a/dev-lua/luaevent-prosody/Manifest b/dev-lua/luaevent-prosody/Manifest
new file mode 100644
index 000000000000..64c4a8c27d92
--- /dev/null
+++ b/dev-lua/luaevent-prosody/Manifest
@@ -0,0 +1,4 @@
+DIST luaevent-prosody-0.1.1.tar.gz 28957 RMD160 4d7612fa33df9a7c5f7b38acb6368b334a7b0f1f SHA1 cd9f4149b324ff26764f3142001398416d909a2c SHA256 accf6a514a2735d26bb1c30b37e956e42a5fa491ce620eed131e023307a95760
+EBUILD luaevent-prosody-0.1.1.ebuild 1480 RMD160 6f347d4e3605702cf6a462039cd92287bd219810 SHA1 1aa93011db852637d3963c32da803a86b1d1f4a6 SHA256 23193dbefb4780ad71dcf0e50afd8819e0dcdc898fa52bff925ae91b6a9e7d82
+MISC ChangeLog 915 RMD160 35acdd31a43d02740aed09e690811c7bc5f6abe2 SHA1 10683d97d8dcf5b0e73bc2167e7b0bf49212a350 SHA256 210e9451c77126667608d1ce406f55df06f05ac39345045415ceb130479a6193
+MISC metadata.xml 302 RMD160 b73de347a51dfb6d0fb5d5704c7e4df9332c345e SHA1 8f2d8060b7ca04ed3a1ed94c26df8ae50ab68b8c SHA256 88698b3e3055b21eaa7e5585c10cc087fb3c0c49994c433f1a765a672e89e25d
diff --git a/dev-lua/luaevent-prosody/luaevent-prosody-0.1.1.ebuild b/dev-lua/luaevent-prosody/luaevent-prosody-0.1.1.ebuild
new file mode 100644
index 000000000000..f5ae00e3558b
--- /dev/null
+++ b/dev-lua/luaevent-prosody/luaevent-prosody-0.1.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/luaevent-prosody/luaevent-prosody-0.1.1.ebuild,v 1.1 2010/11/05 20:03:27 rafaelmartins Exp $
+
+EAPI=2
+
+inherit multilib toolchain-funcs flag-o-matic eutils
+
+DESCRIPTION="libevent bindings for Lua (Prosody's fork)"
+HOMEPAGE="http://code.matthewwild.co.uk/luaevent-prosody"
+SRC_URI="http://matthewwild.co.uk/uploads/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/lua-5.1
+ >=dev-libs/libevent-1.4"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ sed -i -e "s#^INSTALL_DIR_LUA=.*#INSTALL_DIR_LUA=$(pkg-config --variable INSTALL_LMOD lua)#" "${S}/Makefile"
+ sed -i -e "s#^INSTALL_DIR_BIN=.*#INSTALL_DIR_BIN=$(pkg-config --variable INSTALL_CMOD lua)#" "${S}/Makefile"
+ sed -i -e "s#^LUA_INC_DIR=.*#LUA_INC_DIR=$(pkg-config --variable INSTALL_INC lua)#" "${S}/Makefile"
+ sed -i -e "s#^LUA_LIB_DIR=.*#LUA_LIB_DIR=$(pkg-config --variable INSTALL_LIB lua)#" "${S}/Makefile"
+ sed -i -e "s#^LUA_LIB =.*#LUA_LIB=lua#" "${S}/Makefile"
+}
+
+src_compile() {
+ append-flags -fPIC -c
+ emake \
+ CFLAGS="${LDFLAGS} ${CFLAGS}" \
+ LDFLAGS="${LDFLAGS} -shared" \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC) -shared" \
+ all \
+ || die
+}
+
+src_install() {
+ emake \
+ CFLAGS="${LDFLAGS} ${CFLAGS}" \
+ LDFLAGS="${LDFLAGS} -shared" \
+ CC="$(tc-getCC)" \
+ DESTDIR="${D}" install || die "Install failed"
+}
diff --git a/dev-lua/luaevent-prosody/metadata.xml b/dev-lua/luaevent-prosody/metadata.xml
new file mode 100644
index 000000000000..be02d466dcff
--- /dev/null
+++ b/dev-lua/luaevent-prosody/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>djc@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>rafaelmartins@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>