summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2005-05-01 16:46:31 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2005-05-01 16:46:31 +0000
commit726f69f2c45fd8024f5111b176f4c8ee68a5a759 (patch)
treedef35fc5965c52fbd3fa90faacdb7923caf214fc /dev-java/libgnome-java
parentStable on ppc. (diff)
downloadhistorical-726f69f2c45fd8024f5111b176f4c8ee68a5a759.tar.gz
historical-726f69f2c45fd8024f5111b176f4c8ee68a5a759.tar.bz2
historical-726f69f2c45fd8024f5111b176f4c8ee68a5a759.zip
Updates from Andrew, partial fix for #87978.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'dev-java/libgnome-java')
-rw-r--r--dev-java/libgnome-java/ChangeLog10
-rw-r--r--dev-java/libgnome-java/files/digest-libgnome-java-2.10.11
-rw-r--r--dev-java/libgnome-java/files/libgnome-java-2.10.0_fix-install-dir.patch11
-rw-r--r--dev-java/libgnome-java/libgnome-java-2.10.1.ebuild90
4 files changed, 111 insertions, 1 deletions
diff --git a/dev-java/libgnome-java/ChangeLog b/dev-java/libgnome-java/ChangeLog
index e0ed9586fb5a..36f3a82dcbd7 100644
--- a/dev-java/libgnome-java/ChangeLog
+++ b/dev-java/libgnome-java/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-java/libgnome-java
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/libgnome-java/ChangeLog,v 1.8 2005/03/31 18:56:11 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/libgnome-java/ChangeLog,v 1.9 2005/05/01 16:42:39 karltk Exp $
+
+*libgnome-java-2.10.1 (01 May 2005)
+
+ 01 May 2005; Karl Trygve Kalleberg <karltk@gentoo.org>
+ +files/libgnome-java-2.10.0_fix-install-dir.patch,
+ +libgnome-java-2.10.1.ebuild:
+ Updates from Andrew Cowie <andrew@operationaldynamics.com>, partial fix for
+ #87978.
31 Mar 2005; Jan Brinkmann <luckyduck@gentoo.org>
libgnome-java-2.8.2-r1.ebuild, libgnome-java-2.8.2.ebuild,
diff --git a/dev-java/libgnome-java/files/digest-libgnome-java-2.10.1 b/dev-java/libgnome-java/files/digest-libgnome-java-2.10.1
new file mode 100644
index 000000000000..36dc2aabb461
--- /dev/null
+++ b/dev-java/libgnome-java/files/digest-libgnome-java-2.10.1
@@ -0,0 +1 @@
+MD5 c1b47338bafe4c7f89d1cb505c26a8ce libgnome-java-2.10.1.tar.bz2 349490
diff --git a/dev-java/libgnome-java/files/libgnome-java-2.10.0_fix-install-dir.patch b/dev-java/libgnome-java/files/libgnome-java-2.10.0_fix-install-dir.patch
new file mode 100644
index 000000000000..fa21ad94115c
--- /dev/null
+++ b/dev-java/libgnome-java/files/libgnome-java-2.10.0_fix-install-dir.patch
@@ -0,0 +1,11 @@
+--- libgnome-java-2.10.0/Makefile.in 2005-03-06 18:14:01.000000000 -0500
++++ fixed/Makefile.in 2005-04-04 00:39:40.000000000 -0400
+@@ -3072,7 +3072,7 @@
+ $(DOCBOOK) -o doc/doc $<
+
+ install-data-hook:
+- cd $(DESTDIR)$(datadir)/java && \
++ cd $(DESTDIR)$(jardir) && \
+ mv -f gnome$(apiversion).jar gnome$(apiversion)-$(VERSION).jar && \
+ $(LN_S) gnome$(apiversion)-$(VERSION).jar gnome$(apiversion).jar
+
diff --git a/dev-java/libgnome-java/libgnome-java-2.10.1.ebuild b/dev-java/libgnome-java/libgnome-java-2.10.1.ebuild
new file mode 100644
index 000000000000..3e56bdc75b5f
--- /dev/null
+++ b/dev-java/libgnome-java/libgnome-java-2.10.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/libgnome-java/libgnome-java-2.10.1.ebuild,v 1.1 2005/05/01 16:42:39 karltk Exp $
+
+#
+# WARNING: Because java-gnome is a set of bindings to native GNOME libraries,
+# it has, like any GNOME project, a massive autoconf setup, and unlike many
+# other java libraries, it has its own [necessary] `make install` step.
+# As a result, this ebuild is VERY sensitive to the internal layout of the
+# upstream project. Because these issues are currently evolving upstream,
+# simply version bumping this ebuild is not likely to work but FAILURES WILL
+# BE VERY SUBTLE IF IT DOES NOT WORK.
+#
+
+inherit eutils gnome.org
+
+DESCRIPTION="Java bindings for the core GNOME libraries (allow GNOME/GTK applications to be written in Java)"
+HOMEPAGE="http://java-gnome.sourceforge.net/"
+RDEPEND=">=gnome-base/libgnome-2.10.0
+ >=gnome-base/libgnomeui-2.10.0
+ >=gnome-base/libgnomecanvas-2.10.0
+ >=dev-java/libgtk-java-2.6.2
+ >=virtual/jre-1.2"
+
+DEPEND="${RDEPEND}
+ >=virtual/jdk-1.2
+ app-arch/zip"
+
+#
+# Critical that this match the gnome apiversion
+#
+SLOT="2.10"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86 ~ppc"
+IUSE="gcj"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/libgnome-java-2.10.0_fix-install-dir.patch
+
+ sed -i \
+ -e "s:/share/${PN}/:/share/${PN}-${SLOT}/:" \
+ -e "s:/share/java/:/share/${PN}-${SLOT}/lib/:" \
+ configure || die "sed configure error"
+}
+
+src_compile() {
+ local conf
+
+ use gcj || conf="${conf} --without-gcj-compile"
+
+ cd ${S}
+
+ #
+ # Ordinarily, moving things around post `make install` would do
+ # the trick, but there are paths hard coded in .pc files and in the
+ # `make install` step itself that need to be influenced.
+ #
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --with-jardir=/usr/share/${PN}-${SLOT}/lib \
+ ${conf} || die "./configure failed"
+ make || die
+}
+
+src_install() {
+ # workaround Makefile bug not creating necessary parent directories
+
+ make DESTDIR=${D} install || die "install step failed"
+
+ # actually, at time of writing, there were no DOCUMENTS, but leave it here...
+ mv ${D}/usr/share/doc/libgnome${SLOT}-java ${D}/usr/share/doc/${PF}
+
+ dodir /usr/share/${PN}-${SLOT}/src
+ cd ${S}/src/java
+ find . -name '*.java' | xargs zip ${D}/usr/share/${PN}-${SLOT}/src/libgnome-java-${PV}.src.zip
+
+ # again, with dojar misbehaving, better do to this manually for the
+ # time being. Yes, this is bad hard coding, but what in this ebuild isn't?
+
+ echo "DESCRIPTION=${DESCRIPTION}" \
+ > ${D}/usr/share/${PN}-${SLOT}/package.env
+
+ echo "CLASSPATH=/usr/share/${PN}-${SLOT}/lib/gnome${SLOT}.jar" \
+ >> ${D}/usr/share/${PN}-${SLOT}/package.env
+}