summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlistair Bush <ali_bush@gentoo.org>2010-10-08 08:30:16 +0000
committerAlistair Bush <ali_bush@gentoo.org>2010-10-08 08:30:16 +0000
commit90ae8730f13664eb32a38fcf8b708cb0c3da6c30 (patch)
tree20c1214a012d4e571e55afffbf5773e5dbb6ef96 /dev-dotnet
parentVersion Bump - mono-2.8 :D (diff)
downloadhistorical-90ae8730f13664eb32a38fcf8b708cb0c3da6c30.tar.gz
historical-90ae8730f13664eb32a38fcf8b708cb0c3da6c30.tar.bz2
historical-90ae8730f13664eb32a38fcf8b708cb0c3da6c30.zip
Version Bump.
Package-Manager: portage-2.1.9.13/cvs/Linux x86_64
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/xsp/ChangeLog7
-rw-r--r--dev-dotnet/xsp/xsp-2.8.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-dotnet/xsp/ChangeLog b/dev-dotnet/xsp/ChangeLog
index f73477f2c630..de6a8eb532e3 100644
--- a/dev-dotnet/xsp/ChangeLog
+++ b/dev-dotnet/xsp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-dotnet/xsp
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/ChangeLog,v 1.86 2010/10/07 20:05:15 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/ChangeLog,v 1.87 2010/10/08 08:30:16 ali_bush Exp $
+
+*xsp-2.8 (08 Oct 2010)
+
+ 08 Oct 2010; Alistair Bush <ali_bush@gentoo.org> +xsp-2.8.ebuild:
+ Version Bump for mono-2.8
07 Oct 2010; Pacho Ramos <pacho@gentoo.org>
-files/1.2.1/mod-mono-server.confd, -xsp-2.0.ebuild, -xsp-2.4.2.ebuild,
diff --git a/dev-dotnet/xsp/xsp-2.8.ebuild b/dev-dotnet/xsp/xsp-2.8.ebuild
new file mode 100644
index 000000000000..69fd98ab38d1
--- /dev/null
+++ b/dev-dotnet/xsp/xsp-2.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/xsp-2.8.ebuild,v 1.1 2010/10/08 08:30:16 ali_bush Exp $
+
+EAPI=2
+
+inherit go-mono mono
+
+PATCHDIR="${FILESDIR}/2.2/"
+
+DESCRIPTION="XSP is a small web server that can host ASP.NET pages"
+HOMEPAGE="http://www.go-mono.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE=""
+
+RDEPEND="dev-db/sqlite:3"
+DEPEND="${RDEPEND}"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+pkg_preinst() {
+ enewgroup aspnet
+ # Give aspnet home dir of /tmp since it must create ~/.wapi
+ enewuser aspnet -1 -1 /tmp aspnet
+}
+
+src_install() {
+ mv_command="cp -ar" go-mono_src_install
+ newinitd "${PATCHDIR}"/xsp.initd xsp || die
+ newinitd "${PATCHDIR}"/mod-mono-server.initd mod-mono-server || die
+ newconfd "${PATCHDIR}"/xsp.confd xsp || die
+ newconfd "${PATCHDIR}"/mod-mono-server.confd mod-mono-server || die
+
+ keepdir /var/run/aspnet
+}
+
+pkg_postinst() {
+ chown aspnet:aspnet /var/run/aspnet
+}