summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-12-07 22:59:35 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-12-07 22:59:35 +0000
commitfa44c4ba9485ed18d17d3786663c72bde981599b (patch)
tree20c392c7dc721576c5e9da34797965722747b771
parentadded link (diff)
downloadhistorical-fa44c4ba9485ed18d17d3786663c72bde981599b.tar.gz
historical-fa44c4ba9485ed18d17d3786663c72bde981599b.tar.bz2
historical-fa44c4ba9485ed18d17d3786663c72bde981599b.zip
bump
-rw-r--r--sys-kernel/acpi-sources/acpi-sources-2.4.20-r8.ebuild37
-rw-r--r--sys-kernel/acpi-sources/files/digest-acpi-sources-2.4.20-r82
2 files changed, 39 insertions, 0 deletions
diff --git a/sys-kernel/acpi-sources/acpi-sources-2.4.20-r8.ebuild b/sys-kernel/acpi-sources/acpi-sources-2.4.20-r8.ebuild
new file mode 100644
index 000000000000..60f87653b355
--- /dev/null
+++ b/sys-kernel/acpi-sources/acpi-sources-2.4.20-r8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/acpi-sources/acpi-sources-2.4.20-r8.ebuild,v 1.1 2002/12/07 22:59:35 lostlogic Exp $
+
+IUSE="build"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+ETYPE="sources"
+
+inherit kernel || die
+
+OKV="2.4.20"
+
+ACPI_PATCH="acpi-20021205-2.4.20.diff.gz"
+
+#add one of these in if this is for a pre or rc kernel
+#KERN_PATCH="patch-2.4.20-rc1.bz2"
+
+DESCRIPTION="Full sources for the latest ACPI Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ mirror://sourceforge/acpi/${ACPI_PATCH}"
+#http://www.kernel.org/pub/linux/kernel/v2.4/testing/${KERN_PATCH}
+
+KEYWORDS="x86"
+
+src_unpack() {
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+
+ cd linux-${KV}
+
+# bzcat ${DISTDIR}/${KERN_PATCH}|patch -p1 || die "-marcelo patch failed"
+ zcat ${DISTDIR}/${ACPI_PATCH}|patch -p1 || die "-acpi patch failed"
+
+ kernel_universal_unpack
+}
diff --git a/sys-kernel/acpi-sources/files/digest-acpi-sources-2.4.20-r8 b/sys-kernel/acpi-sources/files/digest-acpi-sources-2.4.20-r8
new file mode 100644
index 000000000000..a1f4125fdce8
--- /dev/null
+++ b/sys-kernel/acpi-sources/files/digest-acpi-sources-2.4.20-r8
@@ -0,0 +1,2 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 fccc2fdaecbf4b94a5317eaba18c841b acpi-20021205-2.4.20.diff.gz 557249