From 4efb0441b1179dfd9e9510ff178f3ab81ff48238 Mon Sep 17 00:00:00 2001
From: Alexis Ballier <aballier@gentoo.org>
Date: Wed, 23 Sep 2015 14:04:37 +0200
Subject: ros-meta/image_pipeline: Initial import. Ebuild by me.

Package-Manager: portage-2.2.21
---
 ros-meta/image_pipeline/Manifest                   |  1 +
 .../image_pipeline/image_pipeline-1.12.14.ebuild   | 25 ++++++++++++++++++++++
 ros-meta/image_pipeline/image_pipeline-9999.ebuild | 25 ++++++++++++++++++++++
 ros-meta/image_pipeline/metadata.xml               |  5 +++++
 4 files changed, 56 insertions(+)
 create mode 100644 ros-meta/image_pipeline/Manifest
 create mode 100644 ros-meta/image_pipeline/image_pipeline-1.12.14.ebuild
 create mode 100644 ros-meta/image_pipeline/image_pipeline-9999.ebuild
 create mode 100644 ros-meta/image_pipeline/metadata.xml

(limited to 'ros-meta')

diff --git a/ros-meta/image_pipeline/Manifest b/ros-meta/image_pipeline/Manifest
new file mode 100644
index 000000000000..0cc1356d6b68
--- /dev/null
+++ b/ros-meta/image_pipeline/Manifest
@@ -0,0 +1 @@
+DIST image_pipeline-1.12.14.tar.gz 118296 SHA256 8e3b756932a821b4387b7f86ca9fc5233ebb2a13541b220b866e42ea6f92b17f SHA512 724b6d20edab1436c51a05f4399b852cabab74c5e04dea97f53a256fb512b4dbfc97fd6e7d74d41bfd7d92fe183aa86a993a39b8687c27dc7b7f85d1a1c81b94 WHIRLPOOL 394343ddf299f6c7e26c0a2f45e49edc2c4047a0ccd15885a998fa902bb7373fa44181f06adc222483a285f32df800e0b268485cb2fd98e54956929056868d5d
diff --git a/ros-meta/image_pipeline/image_pipeline-1.12.14.ebuild b/ros-meta/image_pipeline/image_pipeline-1.12.14.ebuild
new file mode 100644
index 000000000000..9552a9142b2e
--- /dev/null
+++ b/ros-meta/image_pipeline/image_pipeline-1.12.14.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Fills the gap between getting raw images from a camera driver and higher-level vision processing"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+	dev-ros/camera_calibration
+	dev-ros/depth_image_proc
+	dev-ros/image_proc
+	dev-ros/image_rotate
+	dev-ros/image_view
+	dev-ros/stereo_image_proc
+"
+DEPEND="${RDEPEND}"
diff --git a/ros-meta/image_pipeline/image_pipeline-9999.ebuild b/ros-meta/image_pipeline/image_pipeline-9999.ebuild
new file mode 100644
index 000000000000..9552a9142b2e
--- /dev/null
+++ b/ros-meta/image_pipeline/image_pipeline-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Fills the gap between getting raw images from a camera driver and higher-level vision processing"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+	dev-ros/camera_calibration
+	dev-ros/depth_image_proc
+	dev-ros/image_proc
+	dev-ros/image_rotate
+	dev-ros/image_view
+	dev-ros/stereo_image_proc
+"
+DEPEND="${RDEPEND}"
diff --git a/ros-meta/image_pipeline/metadata.xml b/ros-meta/image_pipeline/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/ros-meta/image_pipeline/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
-- 
cgit v1.2.3-65-gdbad