From b12421a4c6f4f3599b1f09bf553c724a811f885f Mon Sep 17 00:00:00 2001
From: Mike Gilbert <floppym@gentoo.org>
Date: Mon, 22 Aug 2016 23:00:24 -0400
Subject: net-libs/zeromq: fix 4.1.5

The previous revision only installed manpages.
Bump EAPI and drop autotools-utils while we are at it.
Also depend on asciidoc and xmlto.

Package-Manager: portage-2.3.0_p16
---
 net-libs/zeromq/zeromq-4.1.5-r1.ebuild | 49 ++++++++++++++++++++++++++++++++++
 net-libs/zeromq/zeromq-4.1.5.ebuild    | 49 ----------------------------------
 2 files changed, 49 insertions(+), 49 deletions(-)
 create mode 100644 net-libs/zeromq/zeromq-4.1.5-r1.ebuild
 delete mode 100644 net-libs/zeromq/zeromq-4.1.5.ebuild

(limited to 'net-libs/zeromq')

diff --git a/net-libs/zeromq/zeromq-4.1.5-r1.ebuild b/net-libs/zeromq/zeromq-4.1.5-r1.ebuild
new file mode 100644
index 000000000000..6dc347309e20
--- /dev/null
+++ b/net-libs/zeromq/zeromq-4.1.5-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools eutils
+
+DESCRIPTION="A brokerless kernel"
+HOMEPAGE="http://www.zeromq.org/"
+SRC_URI="https://github.com/zeromq/zeromq4-1/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/5"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="pgm static-libs test"
+
+RDEPEND="
+	dev-libs/libsodium:=
+	pgm? ( =net-libs/openpgm-5.2.122 )"
+DEPEND="${RDEPEND}
+	app-text/asciidoc
+	app-text/xmlto
+	sys-apps/util-linux
+	pgm? ( virtual/pkgconfig )"
+
+src_prepare() {
+	sed \
+		-e '/libzmq_werror=/s:yes:no:g' \
+		-i configure.ac || die
+	default
+	eautoreconf
+}
+
+src_configure() {
+	local myeconfargs=(
+		--enable-shared
+		$(use_enable static-libs static)
+		--with-relaxed
+		--with-libsodium
+		$(use_with pgm)
+	)
+	econf "${myeconfargs[@]}"
+}
+
+src_install() {
+	default
+	prune_libtool_files
+}
diff --git a/net-libs/zeromq/zeromq-4.1.5.ebuild b/net-libs/zeromq/zeromq-4.1.5.ebuild
deleted file mode 100644
index f48bffb4ce67..000000000000
--- a/net-libs/zeromq/zeromq-4.1.5.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-AUTOTOOLS_AUTORECONF=true
-
-inherit autotools-utils
-
-DESCRIPTION="A brokerless kernel"
-HOMEPAGE="http://www.zeromq.org/"
-SRC_URI="https://github.com/zeromq/zeromq4-1/releases/download/v${PV}/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0/5"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="pgm static-libs test"
-
-RDEPEND="
-	dev-libs/libsodium:=
-	pgm? ( =net-libs/openpgm-5.2.122 )"
-DEPEND="${RDEPEND}
-	sys-apps/util-linux
-	pgm? ( virtual/pkgconfig )"
-
-src_prepare() {
-	sed \
-		-e '/libzmq_werror=/s:yes:no:g' \
-		-i configure.ac || die
-	autotools-utils_src_prepare
-}
-
-src_configure() {
-	local myeconfargs=(
-		--with-relaxed
-		--with-libsodium
-		$(use_with pgm)
-	)
-	autotools-utils_src_configure
-}
-
-src_test() {
-	autotools-utils_src_test -j1
-}
-
-src_install() {
-	doman "${BUILD_DIR}"/doc/*.[1-9]
-}
-- 
cgit v1.2.3-65-gdbad