From 3b464906c47a8167497d2800cc1059fcde03012b Mon Sep 17 00:00:00 2001
From: Pacho Ramos <pacho@gentoo.org>
Date: Sat, 2 Jul 2016 18:53:41 +0200
Subject: media-video/totem: Version bump

Package-Manager: portage-2.3.0_rc1
---
 media-video/totem/Manifest            |   1 +
 media-video/totem/totem-3.20.1.ebuild | 131 ++++++++++++++++++++++++++++++++++
 2 files changed, 132 insertions(+)
 create mode 100644 media-video/totem/totem-3.20.1.ebuild

(limited to 'media-video/totem')

diff --git a/media-video/totem/Manifest b/media-video/totem/Manifest
index b2dd03e52c47..b036b7b70395 100644
--- a/media-video/totem/Manifest
+++ b/media-video/totem/Manifest
@@ -1 +1,2 @@
 DIST totem-3.18.1.tar.xz 3172416 SHA256 d7816eae9606846c44fd508902eae10bdaed28e6d4f621531990d473184107a2 SHA512 cc4dcd81c2473a2c91786d0d329d1426cb23c372fbef9738be21762b00aaf02e50f54ed6d6c81b9325312db02347baf267d73d74be4052ffdb14c899e1f4f069 WHIRLPOOL 195b3d62101edaa33ca27238f200b51073810500b552c5ba3592e17ba51f8a4c451e209611b4ceb2d4827856ac20fecc6bf164547e34ab7bbbc77b702cb0b29a
+DIST totem-3.20.1.tar.xz 3190932 SHA256 6f22480361ae869fd336854b4f83614fde528aff4e808eb716de33432eb45c27 SHA512 2dc856d1f911d9ca79a3610ea2616281227d7980801325ec7b6649f46e13ac33b125bcfff79b3954db7358ab764fd8b2fcf7f93a209c4343c8708cb9d8efda62 WHIRLPOOL 6beae91b82c9b92dedf7f399c93d6420259aa5ed6766bfee5763d686cb5126d6c737671af28dfb381e5ea32efe7ad48afe3c72e157b4bdfdeef3c62df3c78102
diff --git a/media-video/totem/totem-3.20.1.ebuild b/media-video/totem/totem-3.20.1.ebuild
new file mode 100644
index 000000000000..208866fa5514
--- /dev/null
+++ b/media-video/totem/totem-3.20.1.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes" # plugins are dlopened
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+PYTHON_REQ_USE="threads"
+
+inherit autotools eutils gnome2 multilib python-single-r1
+
+DESCRIPTION="Media player for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Videos"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+IUSE="debug +introspection lirc nautilus +python test zeitgeist"
+# see bug #359379
+REQUIRED_USE="
+	python? ( introspection ${PYTHON_REQUIRED_USE} )
+	zeitgeist? ( introspection )
+"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+
+# FIXME:
+# Runtime dependency on gnome-session-2.91
+RDEPEND="
+	>=dev-libs/glib-2.35:2[dbus]
+	>=dev-libs/libpeas-1.1[gtk]
+	>=dev-libs/libxml2-2.6:2
+	>=dev-libs/totem-pl-parser-3.10.1:0=[introspection?]
+	>=media-libs/clutter-1.17.3:1.0[gtk]
+	>=media-libs/clutter-gst-2.99.2:3.0
+	>=media-libs/clutter-gtk-1.7.1:1.0
+	>=x11-libs/cairo-1.14
+	>=x11-libs/gdk-pixbuf-2.23.0:2
+	>=x11-libs/gtk+-3.19.4:3[introspection?]
+
+	>=media-libs/grilo-0.3.0:0.3[playlist]
+	media-plugins/grilo-plugins:0.3
+	>=media-libs/gstreamer-1.6.0:1.0
+	>=media-libs/gst-plugins-base-1.6.0:1.0[X,introspection?,pango]
+	media-libs/gst-plugins-good:1.0
+	media-plugins/gst-plugins-meta:1.0
+	media-plugins/gst-plugins-taglib:1.0
+
+	x11-libs/libX11
+
+	gnome-base/gnome-desktop:3=
+	gnome-base/gsettings-desktop-schemas
+	x11-themes/adwaita-icon-theme
+
+	introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+	lirc? ( app-misc/lirc )
+	nautilus? ( >=gnome-base/nautilus-2.91.3 )
+	python? (
+		${PYTHON_DEPS}
+		>=dev-libs/libpeas-1.1.0[${PYTHON_USEDEP}]
+		>=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
+		dev-python/pyxdg[${PYTHON_USEDEP}]
+		dev-python/dbus-python[${PYTHON_USEDEP}]
+		>=x11-libs/gtk+-3.5.2:3[introspection] )
+	zeitgeist? ( >=gnome-extra/zeitgeist-0.9.12 )
+"
+DEPEND="${RDEPEND}
+	app-text/docbook-xml-dtd:4.5
+	app-text/yelp-tools
+	dev-libs/appstream-glib
+	>=dev-util/gtk-doc-am-1.14
+	>=dev-util/intltool-0.50.1
+	sys-devel/gettext
+	virtual/pkgconfig
+	x11-proto/xextproto
+	x11-proto/xproto
+
+	dev-libs/gobject-introspection-common
+	gnome-base/gnome-common
+"
+# eautoreconf needs:
+#	app-text/yelp-tools
+#	dev-libs/gobject-introspection-common
+#	gnome-base/gnome-common
+# docbook-xml-dtd is needed for user doc
+# Prevent dev-python/pylint dep, bug #482538
+
+pkg_setup() {
+	use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+	# Prevent pylint usage by tests, bug #482538
+	sed -i -e 's/ check-pylint//' src/plugins/Makefile.plugins || die
+
+	eautoreconf
+	gnome2_src_prepare
+
+	# FIXME: upstream should provide a way to set GST_INSPECT, bug #358755 & co.
+	# gst-inspect causes sandbox violations when a plugin needs write access to
+	# /dev/dri/card* in its init phase.
+	sed -e "s|\(gst10_inspect=\).*|\1$(type -P true)|" \
+		-i configure || die
+}
+
+src_configure() {
+	# Disabled: sample-python, sample-vala
+	local plugins="apple-trailers,autoload-subtitles,brasero-disc-recorder"
+	plugins+=",im-status,gromit,media-player-keys,ontop"
+	plugins+=",properties,recent,rotation,screensaver,screenshot"
+	plugins+=",skipto,vimeo"
+	use lirc && plugins+=",lirc"
+	use nautilus && plugins+=",save-file"
+	use python && plugins+=",dbusservice,pythonconsole,opensubtitles"
+	use zeitgeist && plugins+=",zeitgeist-dp"
+
+	# pylint is checked unconditionally, but is only used for make check
+	# appstream-util overriding necessary until upstream fixes their macro
+	# to respect configure switch
+	gnome2_src_configure \
+		--disable-run-in-source-tree \
+		--disable-static \
+		--enable-easy-codec-installation \
+		--enable-vala \
+		$(use_enable introspection) \
+		$(use_enable nautilus) \
+		$(use_enable python) \
+		PYLINT=$(type -P true) \
+		VALAC=$(type -P true) \
+		APPSTREAM_UTIL=$(type -P true) \
+		--with-plugins=${plugins}
+}
-- 
cgit v1.2.3-65-gdbad