From 064af661d0c9a31cecdf348632bc5603333a9149 Mon Sep 17 00:00:00 2001
From: Michał Górny <mgorny@gentoo.org>
Date: Tue, 10 Dec 2019 23:02:54 +0100
Subject: */*: [QA] Fix trivial cases of MissingTestRestrict
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

The result was achieved via the following pipeline:

    pkgcheck scan -c RestrictTestCheck -R FormatReporter \
      --format '{category}/{package}/{package}-{version}.ebuild' |
    xargs -n32 grep -L RESTRICT |
    xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"'

The resulting metadata was compared before and after the change.
Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip
added by the eclass.  Two ebuilds have to be fixed because of multiline
IUSE.

Suggested-by: Robin H. Johnson <robbat2@gentoo.org>
Closes: https://github.com/gentoo/gentoo/pull/13942
Signed-off-by: Michał Górny <mgorny@gentoo.org>
---
 dev-python/pygraphviz/pygraphviz-1.3.1.ebuild | 1 +
 dev-python/pygraphviz/pygraphviz-1.5.ebuild   | 1 +
 2 files changed, 2 insertions(+)

(limited to 'dev-python/pygraphviz')

diff --git a/dev-python/pygraphviz/pygraphviz-1.3.1.ebuild b/dev-python/pygraphviz/pygraphviz-1.3.1.ebuild
index 71caf123d655..6165f527d23b 100644
--- a/dev-python/pygraphviz/pygraphviz-1.3.1.ebuild
+++ b/dev-python/pygraphviz/pygraphviz-1.3.1.ebuild
@@ -15,6 +15,7 @@ LICENSE="BSD"
 SLOT="0"
 KEYWORDS="amd64 ~arm64 ~ppc x86 ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
 IUSE="examples test"
+RESTRICT="!test? ( test )"
 
 # Note: only C API of graphviz is used, PYTHON_USEDEP unnecessary.
 RDEPEND="media-gfx/graphviz"
diff --git a/dev-python/pygraphviz/pygraphviz-1.5.ebuild b/dev-python/pygraphviz/pygraphviz-1.5.ebuild
index eaba99b3a524..fa043febb96e 100644
--- a/dev-python/pygraphviz/pygraphviz-1.5.ebuild
+++ b/dev-python/pygraphviz/pygraphviz-1.5.ebuild
@@ -14,6 +14,7 @@ LICENSE="BSD"
 SLOT="0"
 KEYWORDS="amd64 ~arm64 ppc x86 ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
 IUSE="examples test"
+RESTRICT="!test? ( test )"
 
 # Note: only C API of graphviz is used, PYTHON_USEDEP unnecessary.
 RDEPEND="media-gfx/graphviz"
-- 
cgit v1.2.3-65-gdbad