From 56bd759df1d0c750a065b8c845e93d5dfa6b549d Mon Sep 17 00:00:00 2001
From: "Robin H. Johnson" <robbat2@gentoo.org>
Date: Sat, 8 Aug 2015 13:49:04 -0700
Subject: proj/gentoo: Initial commit
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

This commit represents a new era for Gentoo:
Storing the gentoo-x86 tree in Git, as converted from CVS.

This commit is the start of the NEW history.
Any historical data is intended to be grafted onto this point.

Creation process:
1. Take final CVS checkout snapshot
2. Remove ALL ChangeLog* files
3. Transform all Manifests to thin
4. Remove empty Manifests
5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$
5.1. Do not touch files with -kb/-ko keyword flags.

Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests
X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project
X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration
X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn
X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts
X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration
X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging
X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
---
 dev-python/flask-principal/Manifest                |  1 +
 .../flask-principal/flask-principal-0.4.0.ebuild   | 33 ++++++++++++++++++++++
 dev-python/flask-principal/metadata.xml            |  8 ++++++
 3 files changed, 42 insertions(+)
 create mode 100644 dev-python/flask-principal/Manifest
 create mode 100644 dev-python/flask-principal/flask-principal-0.4.0.ebuild
 create mode 100644 dev-python/flask-principal/metadata.xml

(limited to 'dev-python/flask-principal')

diff --git a/dev-python/flask-principal/Manifest b/dev-python/flask-principal/Manifest
new file mode 100644
index 000000000000..8df2b5e67a4b
--- /dev/null
+++ b/dev-python/flask-principal/Manifest
@@ -0,0 +1 @@
+DIST Flask-Principal-0.4.0.tar.gz 5452 SHA256 f5d6134b5caebfdbb86f32d56d18ee44b080876a27269560a96ea35f75c99453 SHA512 18f8f7766af62f99ccd52e34919e3f161ffb727c227c2714d651fad9bf6df3958289389e9b9cfe22d01a150985d1a631db3222626be1c4b12daea22434e4c85e WHIRLPOOL 8bd3dd1d0e5b876fd6cb4cf95b2ed6ce7e077404dd4c2781460dbc333c38c4f0eb55855737ebe0c3042c83c5aa5b7bf4d2c7ca5a9d4b8f8ec9901009b8713c0d
diff --git a/dev-python/flask-principal/flask-principal-0.4.0.ebuild b/dev-python/flask-principal/flask-principal-0.4.0.ebuild
new file mode 100644
index 000000000000..c76e13f84587
--- /dev/null
+++ b/dev-python/flask-principal/flask-principal-0.4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+MY_PN="Flask-Principal"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Identity management for flask"
+HOMEPAGE="http://pythonhosted.org/${MY_PN}/ https://pypi.python.org/pypi/${MY_PN}"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
+	dev-python/blinker[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+	test? ( ${RDEPEND}
+		dev-python/nose[${PYTHON_USEDEP}]
+	)"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+	nosetests || die "Testing failed with ${EPYTHON}"
+}
diff --git a/dev-python/flask-principal/metadata.xml b/dev-python/flask-principal/metadata.xml
new file mode 100644
index 000000000000..ed62904727cf
--- /dev/null
+++ b/dev-python/flask-principal/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+	<herd>python</herd>
+	<upstream>
+		<remote-id type="pypi">Flask-Principal</remote-id>
+	</upstream>
+</pkgmetadata>
-- 
cgit v1.2.3-65-gdbad