From cdc0774a75c8eecd1d68d2b0b1687884b88b9331 Mon Sep 17 00:00:00 2001
From: Michał Górny <mgorny@gentoo.org>
Date: Fri, 8 Nov 2019 21:48:24 +0100
Subject: */*: Inline mirror://hackage and update URIs
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

This change inlines mirror://hackage in all ebuilds, and updates URIs
to the modern form (old URIs redirect to that).

The change has been made using the following command:

find -name '*.ebuild' -exec sed -r -i \
  -e 's@mirror://hackage/@https://hackage.haskell.org/@g' \
  -e 's@https://hackage.haskell.org/packages/archive/([^/]*)/([^/]*)/@https://hackage.haskell.org/package/\1-\2/@g' \
  -e '/hackage\.haskell\.org/s@\$\{PN}-\$\{PV}@${P}@g' \
  -e '/hackage\.haskell\.org/s@\$\{MY_PN}-\$\{PV}@${MY_P}@g' \
  -e '/hackage\.haskell\.org/s@\$\{PN}-\$\{MY_PV}@${MY_P}@g' \
  {} +

Signed-off-by: Michał Górny <mgorny@gentoo.org>
---
 dev-games/goatee/goatee-0.3.0.ebuild   | 4 ++--
 dev-games/goatee/goatee-0.3.1.1.ebuild | 4 ++--
 dev-games/goatee/goatee-0.3.1.2.ebuild | 4 ++--
 3 files changed, 6 insertions(+), 6 deletions(-)

(limited to 'dev-games/goatee')

diff --git a/dev-games/goatee/goatee-0.3.0.ebuild b/dev-games/goatee/goatee-0.3.0.ebuild
index eaa730300920..49c782e9eb7e 100644
--- a/dev-games/goatee/goatee-0.3.0.ebuild
+++ b/dev-games/goatee/goatee-0.3.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -8,7 +8,7 @@ inherit haskell-cabal
 
 DESCRIPTION="A monadic take on a 2,500-year-old board game - library"
 HOMEPAGE="http://khumba.net/projects/goatee"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
 
 LICENSE="AGPL-3"
 SLOT="0/${PV}"
diff --git a/dev-games/goatee/goatee-0.3.1.1.ebuild b/dev-games/goatee/goatee-0.3.1.1.ebuild
index 316620ad346a..5d3870ef90f6 100644
--- a/dev-games/goatee/goatee-0.3.1.1.ebuild
+++ b/dev-games/goatee/goatee-0.3.1.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -10,7 +10,7 @@ inherit haskell-cabal
 
 DESCRIPTION="A monadic take on a 2,500-year-old board game - library"
 HOMEPAGE="http://khumba.net/projects/goatee"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
 
 LICENSE="AGPL-3"
 SLOT="0/${PV}"
diff --git a/dev-games/goatee/goatee-0.3.1.2.ebuild b/dev-games/goatee/goatee-0.3.1.2.ebuild
index 36c88ba4c3ee..29c57774fa08 100644
--- a/dev-games/goatee/goatee-0.3.1.2.ebuild
+++ b/dev-games/goatee/goatee-0.3.1.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -10,7 +10,7 @@ inherit haskell-cabal
 
 DESCRIPTION="A monadic take on a 2,500-year-old board game - library"
 HOMEPAGE="http://khumba.net/projects/goatee"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
 
 LICENSE="AGPL-3"
 SLOT="0/${PV}"
-- 
cgit v1.2.3-65-gdbad