From 76695ad80c518a342f804e0d84c034bf2092f466 Mon Sep 17 00:00:00 2001
From: Nobel Barakat <nobelbarakat@google.com>
Date: Fri, 7 Jan 2022 00:37:27 +0000
Subject: app-editors/vim-core: version bump to v8.2.3950.

This is needed to resolve CVE-2021-4136, CVE-2021-4166, CVE-2021-4187,
CVE-2021-4192, and CVE-2021-4193.

Bug: https://bugs.gentoo.org/829658
Signed-off-by: Nobel Barakat <nobelbarakat@google.com>
Signed-off-by: Sam James <sam@gentoo.org>
---
 app-editors/vim-core/Manifest                 |   1 +
 app-editors/vim-core/vim-core-8.2.3950.ebuild | 233 ++++++++++++++++++++++++++
 2 files changed, 234 insertions(+)
 create mode 100644 app-editors/vim-core/vim-core-8.2.3950.ebuild

(limited to 'app-editors')

diff --git a/app-editors/vim-core/Manifest b/app-editors/vim-core/Manifest
index 667cc80e1a7a..67a02daea629 100644
--- a/app-editors/vim-core/Manifest
+++ b/app-editors/vim-core/Manifest
@@ -5,3 +5,4 @@ DIST vim-8.2.3567.tar.gz 15771981 BLAKE2B 5a10ce998769b73a9c3b30fccb84e90eef8242
 DIST vim-8.2.3582.tar.gz 15778667 BLAKE2B c8eaa95fa4fde6514168a9f42a712a78442a7fe504b59158e2e7717b8025a59cb4d8948451d72418b29f2b7cf3619cd765ef43e1304d73f81a6cba405f9706e7 SHA512 f476f24390807b71a0e02729f1815b3743b6b42cdd28a414e9ceaf0aa3fd4cab91e3550a669b1c64b4cd83207515cfe2b4acf2358a6def60e216e101c979037e
 DIST vim-8.2.3669.tar.gz 15810783 BLAKE2B edac6dabfbeb11057c7b15830b30ec555a10942494bc89d7d85b4c701b5ff8f7413887e4e33e7b812057177ffebd2cdc74e69e86080a86cfee529b1da45156bb SHA512 83d172f7e1a3c5a8ea6238f2766bf077463d32d429111c08e5b28b8aafb8aea584807023281abf3b1710d61820fec8d2b808b42b5c50058d5eb4eb917deb19ab
 DIST vim-8.2.3741.tar.gz 15812097 BLAKE2B 5cd90d4c86774a63a020ac8f245005e3f7df030c1334f989862b17b70d7859d751f79dcaf98eb5216c23df6ce63f3406cb5cb3c643f9e8170987f4f705a49833 SHA512 19ee7cc27642253ad989e6e32ab96faa46b5e1feebba00cadd018af2de186358d686cfa5efbc8e5da00a14ceb42c226acfc81cb11cd87f34ec7ca901c98df814
+DIST vim-8.2.3950.tar.gz 15865929 BLAKE2B e713895f847194845c1a794fc796e97678b11686f51f9a33898d92cf1d3927c6d49cd24024b6c5cbbad82b45ab8293f6d4663f14e66a56cc8b361a5fabdbb0b0 SHA512 d9176f74a1b753fb9118362350b3da16f176c7bc5cc57b41dab1f470c1e80830e4a6f4851d5a090d6efdb272186bd8f6a8a5e08e5da5ae0474560cb32dd626be
diff --git a/app-editors/vim-core/vim-core-8.2.3950.ebuild b/app-editors/vim-core/vim-core-8.2.3950.ebuild
new file mode 100644
index 000000000000..a6ac59db33c3
--- /dev/null
+++ b/app-editors/vim-core/vim-core-8.2.3950.ebuild
@@ -0,0 +1,233 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Please bump with app-editors/vim and app-editors/gvim
+
+VIM_VERSION="8.2"
+inherit estack vim-doc flag-o-matic bash-completion-r1 prefix desktop xdg-utils
+
+if [[ ${PV} == 9999* ]] ; then
+	inherit git-r3
+	EGIT_REPO_URI="https://github.com/vim/vim.git"
+	EGIT_CHECKOUT_DIR=${WORKDIR}/vim-${PV}
+else
+	SRC_URI="https://github.com/vim/vim/archive/v${PV}.tar.gz -> vim-${PV}.tar.gz
+		https://dev.gentoo.org/~zlogene/distfiles/app-editors/vim/vim-8.2.0360-gentoo-patches.tar.xz"
+	KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+S="${WORKDIR}"/vim-${PV}
+
+DESCRIPTION="vim and gvim shared files"
+HOMEPAGE="https://vim.sourceforge.io/ https://github.com/vim/vim"
+
+LICENSE="vim"
+SLOT="0"
+IUSE="nls acl minimal"
+
+BDEPEND="sys-devel/autoconf"
+# Avoid icon file collision, bug #673880
+RDEPEND="!!<app-editors/gvim-8.1.0648"
+PDEPEND="!minimal? ( app-vim/gentoo-syntax )"
+
+pkg_setup() {
+	# people with broken alphabets run into trouble. bug #82186.
+	unset LANG LC_ALL
+	export LC_COLLATE="C"
+
+	# Gnome sandbox silliness. bug #114475.
+	mkdir -p "${T}"/home || die "mkdir -p failed"
+	export HOME="${T}"/home
+}
+
+src_prepare() {
+	if [[ ${PV} != 9999* ]] ; then
+		# Gentoo patches to fix runtime issues, cross-compile errors, etc
+		eapply "${WORKDIR}"/patches
+	fi
+
+	# Fixup a script to use awk instead of nawk
+	sed -i \
+		-e '1s|.*|#!'"${EPREFIX}"'/usr/bin/awk -f|' \
+		"${S}"/runtime/tools/mve.awk || die "sed failed"
+
+	# See bug #77841. We remove this file after the tarball extraction.
+	rm -v "${S}"/runtime/tools/vimspell.sh || die "rm failed"
+
+	# Read vimrc and gvimrc from /etc/vim
+	echo '#define SYS_VIMRC_FILE "'${EPREFIX}'/etc/vim/vimrc"' >> "${S}"/src/feature.h
+	echo '#define SYS_GVIMRC_FILE "'${EPREFIX}'/etc/vim/gvimrc"' >> "${S}"/src/feature.h
+
+	# Use exuberant ctags which installs as /usr/bin/exuberant-ctags.
+	# Hopefully this pattern won't break for a while at least.
+	# This fixes bug #29398 (27 Sep 2003 agriffis)
+	sed -i 's/\<ctags\("\| [-*.]\)/exuberant-&/g' \
+		"${S}"/runtime/doc/syntax.txt \
+		"${S}"/runtime/doc/tagsrch.txt \
+		"${S}"/runtime/doc/usr_29.txt \
+		"${S}"/runtime/menu.vim \
+		"${S}"/src/configure.ac || die 'sed failed'
+
+	# Don't be fooled by /usr/include/libc.h.  When found, vim thinks
+	# this is NeXT, but it's actually just a file in dev-libs/9libs
+	# This fixes bug #43885 (20 Mar 2004 agriffis)
+	sed -i 's/ libc\.h / /' "${S}"/src/configure.ac || die 'sed failed'
+
+	# gcc on sparc32 has this, uhm, interesting problem with detecting EOF
+	# correctly. To avoid some really entertaining error messages about stuff
+	# which isn't even in the source file being invalid, we'll do some trickery
+	# to make the error never occur. bug 66162 (02 October 2004 ciaranm)
+	find "${S}" -name '*.c' | while read c; do
+	    echo >> "$c" || die "echo failed"
+	done
+
+	# Try to avoid sandbox problems. Bug #114475.
+	if [[ -d "${S}"/src/po ]]; then
+		sed -i -e \
+			'/-S check.vim/s,..VIM.,ln -s $(VIM) testvim \; ./testvim -X,' \
+			"${S}"/src/po/Makefile || die "sed failed"
+	fi
+
+	cp -v "${S}"/src/config.mk.dist "${S}"/src/auto/config.mk || die "cp failed"
+
+	# Bug #378107 - Build properly with >=perl-core/ExtUtils-ParseXS-3.20.0
+	sed -i -e \
+		"s:\\\$(PERLLIB)/ExtUtils/xsubpp:${EPREFIX}/usr/bin/xsubpp:" \
+		"${S}"/src/Makefile || die 'sed for ExtUtils-ParseXS failed'
+
+	eapply_user
+}
+
+src_configure() {
+	local myconf
+
+	# Fix bug #37354: Disallow -funroll-all-loops on amd64
+	# Bug 57859 suggests that we want to do this for all archs
+	filter-flags -funroll-all-loops
+
+	# Fix bug #76331: -O3 causes problems, use -O2 instead. We'll do this for
+	# everyone since previous flag filtering bugs have turned out to affect
+	# multiple archs...
+	replace-flags -O3 -O2
+
+	# Fix bug #18245: Prevent "make" from the following chain:
+	# (1) Notice configure.ac is newer than auto/configure
+	# (2) Rebuild auto/configure
+	# (3) Notice auto/configure is newer than auto/config.mk
+	# (4) Run ./configure (with wrong args) to remake auto/config.mk
+	sed -i 's# auto/config\.mk:#:#' src/Makefile || die "Makefile sed failed"
+
+	# Remove src/auto/configure file.
+	rm -v src/auto/configure || die "rm configure failed"
+
+	emake -j1 -C src autoconf
+
+	# This should fix a sandbox violation (see bug 24447). The hvc
+	# things are for ppc64, see bug 86433.
+	for file in /dev/pty/s* /dev/console /dev/hvc/* /dev/hvc*; do
+		if [[ -e "${file}" ]]; then
+			addwrite ${file}
+		fi
+	done
+
+	# Let Portage do the stripping. Some people like that.
+	export ac_cv_prog_STRIP="$(type -P true ) faking strip"
+
+	# Keep Gentoo Prefix env contained within the EPREFIX
+	use prefix && myconf+=" --without-local-dir"
+
+	econf \
+		--with-modified-by=Gentoo-${PVR} \
+		--enable-gui=no \
+		--without-x \
+		--disable-darwin \
+		--disable-perlinterp \
+		--disable-pythoninterp \
+		--disable-rubyinterp \
+		--disable-gpm \
+		--disable-selinux \
+		$(use_enable nls) \
+		$(use_enable acl) \
+		${myconf}
+}
+
+src_compile() {
+	emake -j1 -C src auto/osdef.h objects
+	emake tools
+}
+
+src_test() { :; }
+
+src_install() {
+	local vimfiles=/usr/share/vim/vim${VIM_VERSION/.}
+
+	dodir /usr/{bin,share/{man/man1,vim}}
+	emake -C src \
+		installruntime \
+		installmanlinks \
+		installmacros \
+		installtutor \
+		installtutorbin \
+		installtools \
+		install-languages \
+		DESTDIR="${D}" \
+		BINDIR="${EPREFIX}"/usr/bin \
+		MANDIR="${EPREFIX}"/usr/share/man \
+		DATADIR="${EPREFIX}"/usr/share
+
+	keepdir ${vimfiles}/keymap
+
+	# default vimrc is installed by vim-core since it applies to
+	# both vim and gvim
+	insinto /etc/vim/
+	newins "${FILESDIR}"/vimrc-r5 vimrc
+	eprefixify "${ED}"/etc/vim/vimrc
+
+	if use minimal; then
+		# To save space, install only a subset of the files.
+		# Helps minimalize the livecd, bug 65144.
+		eshopts_push -s extglob
+
+		rm -rv "${ED}${vimfiles}"/{compiler,doc,ftplugin,indent} || die "rm failed"
+		rm -rv "${ED}${vimfiles}"/{macros,print,tools,tutor} || die "rm failed"
+		rm -v "${ED}"/usr/bin/vimtutor || die "rm failed"
+
+		# Delete defaults.vim to avoid conflicts with one from vim[minimal]
+		rm -v "${ED}${vimfiles}"/defaults.vim || die "rm failed"
+
+		local keep_colors="default"
+		ignore=$(rm -fr "${ED}${vimfiles}"/colors/!(${keep_colors}).vim )
+
+		local keep_syntax="conf|crontab|fstab|inittab|resolv|sshdconfig"
+		# tinkering with the next line might make bad things happen ...
+		keep_syntax="${keep_syntax}|syntax|nosyntax|synload"
+		ignore=$(rm -fr "${ED}${vimfiles}"/syntax/!(${keep_syntax}).vim )
+
+		# Delete skip_defaults_vim config not supported by vim[minimal]
+		sed -i '/skip_defaults_vim/d' "${ED}"/etc/vim/vimrc || die "sed failed"
+
+		eshopts_pop
+	fi
+
+	newbashcomp "${FILESDIR}"/xxd-completion xxd
+
+	# install gvim icon since both vim/gvim desktop files reference it
+	doicon -s scalable "${FILESDIR}"/gvim.svg
+}
+
+pkg_postinst() {
+	# update documentation tags (from vim-doc.eclass)
+	update_vim_helptags
+
+	# update icon cache
+	xdg_icon_cache_update
+}
+
+pkg_postrm() {
+	# Update documentation tags (from vim-doc.eclass)
+	update_vim_helptags
+
+	# update icon cache
+	xdg_icon_cache_update
+}
-- 
cgit v1.2.3-65-gdbad