summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/aewm++')
-rw-r--r--x11-wm/aewm++/aewm++-1.1.5-r2.ebuild19
1 files changed, 7 insertions, 12 deletions
diff --git a/x11-wm/aewm++/aewm++-1.1.5-r2.ebuild b/x11-wm/aewm++/aewm++-1.1.5-r2.ebuild
index 843c906b41a9..601677e367b8 100644
--- a/x11-wm/aewm++/aewm++-1.1.5-r2.ebuild
+++ b/x11-wm/aewm++/aewm++-1.1.5-r2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils toolchain-funcs
+EAPI=6
+inherit toolchain-funcs
DESCRIPTION="A window manager with more modern features than aewm"
HOMEPAGE="https://github.com/frankhale/aewmpp"
@@ -19,16 +19,11 @@ DEPEND="${RDEPEND}
x11-proto/xextproto
x11-proto/xproto"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc43.patch \
- "${FILESDIR}"/${P}-makefile.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-makefile.patch
+)
src_compile() {
emake CXX="$(tc-getCXX)"
}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc ChangeLog README
-}