summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/compiler-rt/compiler-rt-13.0.0.ebuild4
-rw-r--r--sys-libs/compiler-rt/compiler-rt-13.0.1.9999.ebuild4
-rw-r--r--sys-libs/compiler-rt/compiler-rt-13.0.1_rc1.ebuild4
-rw-r--r--sys-libs/compiler-rt/compiler-rt-14.0.0.9999.ebuild4
4 files changed, 12 insertions, 4 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-13.0.0.ebuild b/sys-libs/compiler-rt/compiler-rt-13.0.0.ebuild
index 564c29b11eaa..a2d62590de11 100644
--- a/sys-libs/compiler-rt/compiler-rt-13.0.0.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-13.0.0.ebuild
@@ -26,7 +26,9 @@ BDEPEND="
$(python_gen_any_dep ">=dev-python/lit-9.0.1[\${PYTHON_USEDEP}]")
=sys-devel/clang-${PV%_*}*:${CLANG_SLOT}
)
- ${PYTHON_DEPS}"
+ !test? (
+ ${PYTHON_DEPS}
+ )"
LLVM_COMPONENTS=( compiler-rt )
LLVM_PATCHSET=${PV/_/-}
diff --git a/sys-libs/compiler-rt/compiler-rt-13.0.1.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-13.0.1.9999.ebuild
index 0a82b041cbde..1f0bd3af8c06 100644
--- a/sys-libs/compiler-rt/compiler-rt-13.0.1.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-13.0.1.9999.ebuild
@@ -26,7 +26,9 @@ BDEPEND="
$(python_gen_any_dep ">=dev-python/lit-9.0.1[\${PYTHON_USEDEP}]")
=sys-devel/clang-${PV%_*}*:${CLANG_SLOT}
)
- ${PYTHON_DEPS}"
+ !test? (
+ ${PYTHON_DEPS}
+ )"
LLVM_COMPONENTS=( compiler-rt )
LLVM_PATCHSET=9999-1
diff --git a/sys-libs/compiler-rt/compiler-rt-13.0.1_rc1.ebuild b/sys-libs/compiler-rt/compiler-rt-13.0.1_rc1.ebuild
index 3c0553bcebbd..b2851d32c00e 100644
--- a/sys-libs/compiler-rt/compiler-rt-13.0.1_rc1.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-13.0.1_rc1.ebuild
@@ -26,7 +26,9 @@ BDEPEND="
$(python_gen_any_dep ">=dev-python/lit-9.0.1[\${PYTHON_USEDEP}]")
=sys-devel/clang-${PV%_*}*:${CLANG_SLOT}
)
- ${PYTHON_DEPS}"
+ !test? (
+ ${PYTHON_DEPS}
+ )"
LLVM_COMPONENTS=( compiler-rt )
LLVM_PATCHSET=${PV/_/-}
diff --git a/sys-libs/compiler-rt/compiler-rt-14.0.0.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-14.0.0.9999.ebuild
index 3d2048549e73..98c8fe855cfe 100644
--- a/sys-libs/compiler-rt/compiler-rt-14.0.0.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-14.0.0.9999.ebuild
@@ -26,7 +26,9 @@ BDEPEND="
$(python_gen_any_dep ">=dev-python/lit-9.0.1[\${PYTHON_USEDEP}]")
=sys-devel/clang-${PV%_*}*:${CLANG_SLOT}
)
- ${PYTHON_DEPS}"
+ !test? (
+ ${PYTHON_DEPS}
+ )"
LLVM_COMPONENTS=( compiler-rt cmake )
LLVM_PATCHSET=9999-1