summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/rtkit')
-rw-r--r--sys-auth/rtkit/rtkit-0.11-r2.ebuild17
1 files changed, 11 insertions, 6 deletions
diff --git a/sys-auth/rtkit/rtkit-0.11-r2.ebuild b/sys-auth/rtkit/rtkit-0.11-r2.ebuild
index baed267c8c7f..05f9d6ba609e 100644
--- a/sys-auth/rtkit/rtkit-0.11-r2.ebuild
+++ b/sys-auth/rtkit/rtkit-0.11-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -23,6 +23,13 @@ DEPEND="${DEPEND}
app-arch/xz-utils
"
+PATCHES=(
+ # Fedora patches
+ "${FILESDIR}/${P}-polkit.patch"
+ "${FILESDIR}/${P}-gettime.patch"
+ "${FILESDIR}/${P}-controlgroup.patch"
+)
+
pkg_pretend() {
if use kernel_linux; then
CONFIG_CHECK="~!RT_GROUP_SCHED"
@@ -39,15 +46,13 @@ pkg_setup() {
}
src_prepare() {
- # Fedora patches
- epatch "${FILESDIR}"/${P}-polkit.patch
- epatch "${FILESDIR}"/${P}-gettime.patch
- epatch "${FILESDIR}"/${P}-controlgroup.patch
+ default
eautoreconf
}
src_configure() {
- econf $(systemd_with_unitdir)
+ econf \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
}
src_install() {