summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/voro++')
-rw-r--r--sci-libs/voro++/files/voro++-0.4.6-cmake.patch8
-rw-r--r--sci-libs/voro++/voro++-0.4.6-r1.ebuild13
2 files changed, 10 insertions, 11 deletions
diff --git a/sci-libs/voro++/files/voro++-0.4.6-cmake.patch b/sci-libs/voro++/files/voro++-0.4.6-cmake.patch
index 375d58f6474e..c848748c5cf7 100644
--- a/sci-libs/voro++/files/voro++-0.4.6-cmake.patch
+++ b/sci-libs/voro++/files/voro++-0.4.6-cmake.patch
@@ -1,7 +1,7 @@
Index: CMakeLists.txt
===================================================================
---- CMakeLists.txt (revision 0)
-+++ CMakeLists.txt (working copy)
+--- a/CMakeLists.txt (revision 0)
++++ b/CMakeLists.txt (working copy)
@@ -0,0 +1,109 @@
+cmake_minimum_required(VERSION 2.6)
+
@@ -114,8 +114,8 @@ Index: CMakeLists.txt
+add_custom_target(uninstall COMMAND ${CMAKE_COMMAND} -P ${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake)
Index: CMakeModules/cmake_uninstall.cmake.in
===================================================================
---- CMakeModules/cmake_uninstall.cmake.in (revision 0)
-+++ CMakeModules/cmake_uninstall.cmake.in (working copy)
+--- a/CMakeModules/cmake_uninstall.cmake.in (revision 0)
++++ b/CMakeModules/cmake_uninstall.cmake.in (working copy)
@@ -0,0 +1,22 @@
+IF(NOT EXISTS "@CMAKE_CURRENT_BINARY_DIR@/install_manifest.txt")
+ MESSAGE(FATAL_ERROR "Cannot find install manifest: \"@CMAKE_CURRENT_BINARY_DIR@/install_manifest.txt\"")
diff --git a/sci-libs/voro++/voro++-0.4.6-r1.ebuild b/sci-libs/voro++/voro++-0.4.6-r1.ebuild
index 1f1aa5a860ae..203bee51e027 100644
--- a/sci-libs/voro++/voro++-0.4.6-r1.ebuild
+++ b/sci-libs/voro++/voro++-0.4.6-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-inherit cmake-utils multilib
+inherit cmake-utils
DESCRIPTION="A 3D Voronoi cell software library"
HOMEPAGE="http://math.lbl.gov/voro++/"
@@ -14,12 +14,11 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
-DEPEND=""
-RDEPEND="${DEPEND}"
-
PATCHES=( "${FILESDIR}/${P}-cmake.patch" )
src_configure() {
- mycmakeargs=( -DLIB=$(get_libdir) )
+ local mycmakeargs=(
+ -DLIB=$(get_libdir)
+ )
cmake-utils_src_configure
}