summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/ices/files/ices.initd17
-rw-r--r--net-misc/ices/ices-2.0.2.ebuild42
2 files changed, 0 insertions, 59 deletions
diff --git a/net-misc/ices/files/ices.initd b/net-misc/ices/files/ices.initd
deleted file mode 100644
index ada3b4943e28..000000000000
--- a/net-misc/ices/files/ices.initd
+++ /dev/null
@@ -1,17 +0,0 @@
-#!/sbin/openrc-run
-
-depend() {
- need net
-}
-
-start() {
- ebegin "Starting IceS 2"
- start-stop-daemon --background --start --pidfile /var/run/ices.pid --make-pidfile --exec /usr/bin/ices /etc/ices2/ices.xml
- eend $?
-}
-
-stop() {
- ebegin "Stopping IceS 2"
- start-stop-daemon --stop --pidfile /var/run/ices.pid --name ices
- eend $?
-}
diff --git a/net-misc/ices/ices-2.0.2.ebuild b/net-misc/ices/ices-2.0.2.ebuild
deleted file mode 100644
index 34319a5138bc..000000000000
--- a/net-misc/ices/ices-2.0.2.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit user
-
-DESCRIPTION="Icecast OGG streaming client, supports on the fly re-encoding"
-HOMEPAGE="https://icecast.org/ices/"
-SRC_URI="http://downloads.xiph.org/releases/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ppc64 sparc x86"
-IUSE=""
-
-RDEPEND="dev-libs/libxml2
- >=media-libs/libshout-2
- >=media-libs/libvorbis-1"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-pkg_setup() {
- enewgroup ices
- enewuser ices -1 -1 -1 ices
-}
-
-src_configure() {
- econf --sysconfdir=/etc/ices2
-}
-
-src_install() {
- default
- insinto /etc/ices2
- doins conf/*.xml
- dohtml doc/*.{html,css}
- newinitd "${FILESDIR}"/ices.initd-r1 ices
- keepdir /var/log/ices
- fperms 660 /var/log/ices
- fowners ices:ices /var/log/ices
- rm -rf "${D}"/usr/share/ices
-}