summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/vidstab')
-rw-r--r--media-libs/vidstab/files/vidstab-1.1.0-tests-1.1.0-fix-test_motiondetect-without-openmp.patch26
-rw-r--r--media-libs/vidstab/vidstab-1.1.0-r1.ebuild1
2 files changed, 27 insertions, 0 deletions
diff --git a/media-libs/vidstab/files/vidstab-1.1.0-tests-1.1.0-fix-test_motiondetect-without-openmp.patch b/media-libs/vidstab/files/vidstab-1.1.0-tests-1.1.0-fix-test_motiondetect-without-openmp.patch
new file mode 100644
index 000000000000..88d260f429ca
--- /dev/null
+++ b/media-libs/vidstab/files/vidstab-1.1.0-tests-1.1.0-fix-test_motiondetect-without-openmp.patch
@@ -0,0 +1,26 @@
+From a6438c4b3ea5a00f2896b903a4bda0a4efa241f4 Mon Sep 17 00:00:00 2001
+From: Craig Andrews <candrews@integralblue.com>
+Date: Tue, 12 Feb 2019 16:39:06 -0500
+Subject: [PATCH] Use OpenMP only if available in test_motiondetect
+
+Only call `omp_set_dynamic( 1 );` if `USE_OMP`
+
+Fixes `undefined reference to `omp_set_dynamic'` when not using OpenMP
+---
+ tests/test_motiondetect.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/tests/test_motiondetect.c b/tests/test_motiondetect.c
+index 0f37def..125f4bd 100644
+--- a/tests/test_motiondetect.c
++++ b/tests/test_motiondetect.c
+@@ -19,7 +19,9 @@ void test_motionDetect(TestData* testdata){
+ int i;
+
+ int start = timeOfDayinMS();
++#ifdef USE_OMP
+ omp_set_dynamic( 1 );
++#endif
+ md.conf.numThreads=threads;
+
+ for(i=0; i<numruns; i++){
diff --git a/media-libs/vidstab/vidstab-1.1.0-r1.ebuild b/media-libs/vidstab/vidstab-1.1.0-r1.ebuild
index fd52d76ac3e5..cf1db90cbdc0 100644
--- a/media-libs/vidstab/vidstab-1.1.0-r1.ebuild
+++ b/media-libs/vidstab/vidstab-1.1.0-r1.ebuild
@@ -25,6 +25,7 @@ IUSE="openmp cpu_flags_x86_sse2"
PATCHES=(
"${FILESDIR}/vidstab-1.1.0-tests-should-exit-with-code-0-on-success.patch"
"${FILESDIR}/vidstab-1.1.0-tests-use-sse2-only-if-available.patch"
+ "${FILESDIR}/vidstab-1.1.0-tests-1.1.0-fix-test_motiondetect-without-openmp.patch"
)
src_prepare() {
# USE=cpu_flags_x86_sse2 instead