summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/moto')
-rw-r--r--dev-python/moto/moto-2.2.6.ebuild7
-rw-r--r--dev-python/moto/moto-2.2.9.ebuild1
2 files changed, 6 insertions, 2 deletions
diff --git a/dev-python/moto/moto-2.2.6.ebuild b/dev-python/moto/moto-2.2.6.ebuild
index e8cd22eb118b..ebe2646585e9 100644
--- a/dev-python/moto/moto-2.2.6.ebuild
+++ b/dev-python/moto/moto-2.2.6.ebuild
@@ -61,10 +61,13 @@ python_prepare_all() {
}
python_test() {
- local ignore=(
+ local EPYTEST_IGNORE=(
# incompatible versions?
tests/test_core/test_decorator_calls.py
tests/test_s3/test_s3_classdecorator.py
+ )
+
+ local EPYTEST_DESELECT=(
# Needs network (or docker?) but not marked as such, bug #807031
# TODO: report upstream
tests/test_batch/test_batch_jobs.py::test_terminate_job
@@ -77,5 +80,5 @@ python_test() {
# pytest-django causes freezegun try to mangle stuff inside django
# which fails when django is not really used
- epytest -p no:django -m 'not network' ${ignore[@]/#/--ignore }
+ epytest -p no:django -m 'not network'
}
diff --git a/dev-python/moto/moto-2.2.9.ebuild b/dev-python/moto/moto-2.2.9.ebuild
index 90b1a6e1227e..5369dcc49444 100644
--- a/dev-python/moto/moto-2.2.9.ebuild
+++ b/dev-python/moto/moto-2.2.9.ebuild
@@ -69,6 +69,7 @@ python_test() {
tests/test_swf/responses/test_timeouts.py::test_activity_task_heartbeat_timeout_boto3
tests/test_swf/responses/test_timeouts.py::test_decision_task_start_to_close_timeout_boto3
tests/test_swf/responses/test_timeouts.py::test_workflow_execution_start_to_close_timeout_boto3
+
# Needs network (or docker?) but not marked as such, bug #807031
# TODO: report upstream
tests/test_batch/test_batch_jobs.py::test_terminate_job