summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Video-Info/Video-Info-0.993.0-r2.ebuild28
-rw-r--r--dev-perl/Video-Info/metadata.xml11
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-perl/Video-Info/Video-Info-0.993.0-r2.ebuild b/dev-perl/Video-Info/Video-Info-0.993.0-r2.ebuild
new file mode 100644
index 000000000000..970b260fa933
--- /dev/null
+++ b/dev-perl/Video-Info/Video-Info-0.993.0-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=ALLENDAY
+DIST_VERSION=0.993
+inherit perl-module
+
+DESCRIPTION="Perl extension for getting video info"
+
+LICENSE="Aladdin"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="dev-perl/Class-MakeMethods"
+DEPEND="${RDEPEND}
+ test? (
+ dev-perl/MP3-Info
+ )
+"
+PERL_RM_FILES=(
+ # Can't be bothered packaging both Video::OpenQuicktime and libopenquicktime
+ "t/Quicktime.t"
+ # Broken, TODO: Work out what's wrong
+ "t/MPEG.t"
+)
diff --git a/dev-perl/Video-Info/metadata.xml b/dev-perl/Video-Info/metadata.xml
index 30d9a5f2d860..f6f641e5f9d9 100644
--- a/dev-perl/Video-Info/metadata.xml
+++ b/dev-perl/Video-Info/metadata.xml
@@ -7,5 +7,16 @@
</maintainer>
<upstream>
<remote-id type="cpan">Video-Info</remote-id>
+ <remote-id type="cpan-module">Video::Info</remote-id>
+ <remote-id type="cpan-module">Video::Info::ASF</remote-id>
+ <remote-id type="cpan-module">Video::Info::FOO</remote-id>
+ <remote-id type="cpan-module">Video::Info::MPEG</remote-id>
+ <remote-id type="cpan-module">Video::Info::MPEG::Audio</remote-id>
+ <remote-id type="cpan-module">Video::Info::MPEG::Constants</remote-id>
+ <remote-id type="cpan-module">Video::Info::MPEG::System</remote-id>
+ <remote-id type="cpan-module">Video::Info::MPEG::Video</remote-id>
+ <remote-id type="cpan-module">Video::Info::Magic</remote-id>
+ <remote-id type="cpan-module">Video::Info::Quicktime</remote-id>
+ <remote-id type="cpan-module">Video::Info::RIFF</remote-id>
</upstream>
</pkgmetadata>