summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/docutils-glep/docutils-glep-0.4-r1.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/dev-python/docutils-glep/docutils-glep-0.4-r1.ebuild b/dev-python/docutils-glep/docutils-glep-0.4-r1.ebuild
index a7b483de1371..3fc69600a5dd 100644
--- a/dev-python/docutils-glep/docutils-glep-0.4-r1.ebuild
+++ b/dev-python/docutils-glep/docutils-glep-0.4-r1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4} pypy )
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
-inherit eutils python-r1
+inherit python-r1
MY_P=${PF/docutils-/}
@@ -17,13 +17,16 @@ LICENSE="public-domain"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND=">=dev-python/docutils-0.10[${PYTHON_USEDEP}]"
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-python/docutils-0.10[${PYTHON_USEDEP}]"
S=${WORKDIR}/${MY_P}
src_prepare() {
- epatch_user
+ default
# It's easier to move them around now.
# TODO: add python_newmodule?