summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-05-02 01:55:05 +0200
committerMatt Turner <mattst88@gentoo.org>2021-05-02 11:24:45 -0400
commitbc3bb3e12f583bd7593524294726a44536e235f6 (patch)
tree7ec78b6802ac439538d5b25e01afea5eecdbc90b /x11-drivers
parentx11-drivers/xf86-input-wacom: Define XORG_CONFIGURE_OPTIONS in src_configure (diff)
downloadgentoo-bc3bb3e12f583bd7593524294726a44536e235f6.tar.gz
gentoo-bc3bb3e12f583bd7593524294726a44536e235f6.tar.bz2
gentoo-bc3bb3e12f583bd7593524294726a44536e235f6.zip
x11-drivers/xf86-video-amdgpu: Define XORG_CONFIGURE_OPTIONS in src_configure
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-19.1.0.ebuild7
-rw-r--r--x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild7
2 files changed, 8 insertions, 6 deletions
diff --git a/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-19.1.0.ebuild b/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-19.1.0.ebuild
index 983936d2565a..92c575e22710 100644
--- a/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-19.1.0.ebuild
+++ b/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-19.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -24,9 +24,10 @@ PATCHES=(
"${FILESDIR}"/${P}-Fix-link-failure-with-gcc-10.patch
)
-pkg_setup() {
- XORG_CONFIGURE_OPTIONS=(
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
--enable-glamor
$(use_enable udev)
)
+ xorg-3_src_configure
}
diff --git a/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild b/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild
index 726d5faa862f..813a3cda17ac 100644
--- a/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild
+++ b/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,9 +20,10 @@ RDEPEND=">=x11-libs/libdrm-2.4.89[video_cards_amdgpu]
udev? ( virtual/libudev:= )"
DEPEND="${RDEPEND}"
-pkg_setup() {
- XORG_CONFIGURE_OPTIONS=(
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
--enable-glamor
$(use_enable udev)
)
+ xorg-3_src_configure
}