summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-26 18:44:22 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-26 18:44:22 +0200
commitb49817e6b46390386507f987bcf31c48b56a00d4 (patch)
treed59462b9281c97f93e096e0daee2123802d256b5 /dev-python/vcrpy
parentsys-cluster/sanlock: Stabilize 3.8.5 hppa, #905776 (diff)
downloadgentoo-b49817e6b46390386507f987bcf31c48b56a00d4.tar.gz
gentoo-b49817e6b46390386507f987bcf31c48b56a00d4.tar.bz2
gentoo-b49817e6b46390386507f987bcf31c48b56a00d4.zip
dev-python/vcrpy: Bump to 4.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/vcrpy')
-rw-r--r--dev-python/vcrpy/Manifest1
-rw-r--r--dev-python/vcrpy/vcrpy-4.3.1.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/vcrpy/Manifest b/dev-python/vcrpy/Manifest
index 7a7a8f951520..047f3e2be9cf 100644
--- a/dev-python/vcrpy/Manifest
+++ b/dev-python/vcrpy/Manifest
@@ -1,2 +1,3 @@
DIST vcrpy-4.2.1.gh.tar.gz 331180 BLAKE2B 345e4c148963e2109d02be4e96986083236bd29fa8049c7cc54483f12d0506cde5c116b6f2fe80e099599b22a73e2f6240f7bb91e4a7d8af7f4e8e741097160d SHA512 59231e5164cda3099b18d099f0ef97e062e6401e52e5dfc4022aa89ca02881e9e6e3c782f12c288f5281b3b3bf175dc33a267bc6d2b40791582a1221f5d7aaab
DIST vcrpy-4.3.0.gh.tar.gz 331605 BLAKE2B 92f995d21d986c20445ca6200778e9097fce7d4e44e8812018d5bf04b5f8f93bacf922f5332af59d3e147d6f43d8e3ab4afbbd65ba1314b760479029a64d01bd SHA512 772eb9cf23336ff961fc381a878a4e3e7a1cd81bbd6282f5a945536fd1c6b6d866fecfcfa582c9305de045e953186fea857a18d9f66012be36833d3a489b52ec
+DIST vcrpy-4.3.1.gh.tar.gz 332412 BLAKE2B c2de3c9c3398bfe132b8a103566c6b1f48532d909d9c015b02349ef1283757ac75a31730f35b66ba211aaa1c015ffdf026da388a0a272deac2736e9e57d8ef32 SHA512 3ba3354ec0f1b8985890e70c6adff3416350adfa9dfec1db99051c2e1271f321bddf6e2dcd736a77ef953b71e4b5b0555cf05273443231e87a180f52b2372c9a
diff --git a/dev-python/vcrpy/vcrpy-4.3.1.ebuild b/dev-python/vcrpy/vcrpy-4.3.1.ebuild
new file mode 100644
index 000000000000..889819e817e3
--- /dev/null
+++ b/dev-python/vcrpy/vcrpy-4.3.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically mock your HTTP interactions to simplify and speed up testing"
+HOMEPAGE="
+ https://github.com/kevin1024/vcrpy/
+ https://pypi.org/project/vcrpy/
+"
+SRC_URI="
+ https://github.com/kevin1024/vcrpy/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/six-1.5[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/wrapt[${PYTHON_USEDEP}]
+ dev-python/yarl[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # these tests require Internet
+ tests/integration/test_aiohttp.py
+ tests/integration/test_boto.py
+ tests/integration/test_config.py
+ tests/integration/test_disksaver.py
+ tests/integration/test_httplib2.py::test_effective_url
+ tests/integration/test_httpx.py
+ tests/integration/test_record_mode.py::test_new_episodes_record_mode_two_times
+ tests/integration/test_register_matcher.py
+ tests/integration/test_tornado.py
+ tests/integration/test_urllib2.py
+ tests/integration/test_urllib3.py::test_redirects
+ tests/integration/test_wild.py::test_amazon_doctype
+ tests/integration/test_wild.py::test_flickr_should_respond_with_200
+ tests/unit/test_stubs.py::TestVCRConnection::testing_connect
+ )
+
+ local -x REQUESTS_CA_BUNDLE=$("${EPYTHON}" -m pytest_httpbin.certs)
+ epytest
+}