summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-26 20:47:47 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-26 20:54:43 +0200
commitdb745c5489363ca04e15a07e7c1b147d62595910 (patch)
tree73949e80fc37468c10c23381576e43b7a71cb718 /dev-python/pytest-subtests
parentdev-python/semantic_version: Bump to 2.10.0 (diff)
downloadgentoo-db745c5489363ca04e15a07e7c1b147d62595910.tar.gz
gentoo-db745c5489363ca04e15a07e7c1b147d62595910.tar.bz2
gentoo-db745c5489363ca04e15a07e7c1b147d62595910.zip
dev-python/pytest-subtests: Bump to 0.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-subtests')
-rw-r--r--dev-python/pytest-subtests/Manifest1
-rw-r--r--dev-python/pytest-subtests/pytest-subtests-0.8.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/pytest-subtests/Manifest b/dev-python/pytest-subtests/Manifest
index ca91c3210ad4..e22b7cd95ed7 100644
--- a/dev-python/pytest-subtests/Manifest
+++ b/dev-python/pytest-subtests/Manifest
@@ -1 +1,2 @@
DIST pytest-subtests-0.7.0.gh.tar.gz 9714 BLAKE2B 027badb226c6889ed2fb809eb0b3944ef227a804ea58562fe9337f37526a07a41b11cdfd356d8e9a29f9affc9d0702dead59045db9781504c92186ee613ccb1a SHA512 96531a42c06a20cdf3f3665993d3e80d198a60d536246f4dc46df20b56e47f3f6fdce9478351a8922e370435f974e63d565550213fbbeed8487eedc131f46404
+DIST pytest-subtests-0.8.0.gh.tar.gz 9767 BLAKE2B 707f6744f1cd7723d7bee11f5e535750fa179e7ad3912cd94d5200002e1dc0a206cbdb5c3bc8be587a1c81342ef9d6a8a397acd08388096a484feca6f9c84e0c SHA512 0164e02c81685108bb5c12f7e7ce92dc2fd5c844be454b2cb26e3cb942d51c453f06bb48e0300438a82b28c747dea35ea4f75eaf65ff8b66b338bcb0f0dd9ed1
diff --git a/dev-python/pytest-subtests/pytest-subtests-0.8.0.ebuild b/dev-python/pytest-subtests/pytest-subtests-0.8.0.ebuild
new file mode 100644
index 000000000000..2882f156ab50
--- /dev/null
+++ b/dev-python/pytest-subtests/pytest-subtests-0.8.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="unittest subTest() support and subtests fixture"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-subtests/
+ https://pypi.org/project/pytest-subtests/"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-subtests/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-7[${PYTHON_USEDEP}]
+"
+# pytest-xdist is used to test compatibility
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked,pytest_subtests
+ local EPYTEST_DESELECT=()
+ [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
+ # broken by output changes
+ # https://github.com/pytest-dev/pytest-subtests/issues/69
+ "tests/test_subtests.py::TestSubTest::test_simple_terminal_normal[unittest]"
+ "tests/test_subtests.py::TestSubTest::test_simple_terminal_verbose[unittest]"
+ )
+
+ epytest
+}