aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-09-17 15:30:18 -0400
committerJosh Triplett <josh@freedesktop.org>2007-09-19 13:47:54 -0700
commitc7cdb035e706b69257a8815b80bb5c1880abc4c1 (patch)
tree0202dff6827ef064ec4085d46ff11c62807296c8 /Makefile
parentAdded a prototype for mempcpy(). (diff)
downloadsparse-c7cdb035e706b69257a8815b80bb5c1880abc4c1.tar.gz
sparse-c7cdb035e706b69257a8815b80bb5c1880abc4c1.tar.bz2
sparse-c7cdb035e706b69257a8815b80bb5c1880abc4c1.zip
fix install perms of manpages
the install step for manpages currently does not use the -m option which means perms default to 755 which makes no sense for man pages Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 2475e12..bd5fb96 100644
--- a/Makefile
+++ b/Makefile
@@ -81,7 +81,7 @@ install: $(INST_PROGRAMS) $(LIBS) $(LIB_H) sparse.pc
$(QUIET_INST_SH)install -v $$f $(DESTDIR)$(BINDIR)/$$f || exit 1; \
done
$(Q)for f in $(INST_MAN1); do \
- $(QUIET_INST_SH)install -v $$f $(DESTDIR)$(MAN1DIR)/$$f || exit 1; \
+ $(QUIET_INST_SH)install -m 644 -v $$f $(DESTDIR)$(MAN1DIR)/$$f || exit 1; \
done
$(Q)for f in $(LIBS); do \
$(QUIET_INST_SH)install -m 644 -v $$f $(DESTDIR)$(LIBDIR)/$$f || exit 1; \