aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Li <sparse@chrisli.org>2007-01-16 18:33:42 -0800
committerJosh Triplett <josh@freedesktop.org>2007-01-16 20:17:52 -0800
commita77a4bce372094fc3bab441fa8c136c4544d24ff (patch)
tree33ce139624c414c460d1b9cd6628c1fc65fc6e2b /Makefile
parentRemove old SCCS target from Makefile. (diff)
downloadsparse-a77a4bce372094fc3bab441fa8c136c4544d24ff.tar.gz
sparse-a77a4bce372094fc3bab441fa8c136c4544d24ff.tar.bz2
sparse-a77a4bce372094fc3bab441fa8c136c4544d24ff.zip
Sparse-based Ctags implementation
Here is my attempt to write a Ctags base on sparse. It depends on the result from actually preprocessing the C source file. It can handle the tags from macro expansion. It works well enough for me to locate "int32_t" and "clear_token_alloc". This is the updated ctags that actually generates output to a tags file. Signed-Off-By: Christopher Li <sparse@chrisli.org> Signed-Off-By: Josh Triplett <josh@freedesktop.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 3bc789b..f7c647b 100644
--- a/Makefile
+++ b/Makefile
@@ -22,7 +22,8 @@ LIBDIR=$(PREFIX)/lib
INCLUDEDIR=$(PREFIX)/include
PKGCONFIGDIR=$(PREFIX)/share/pkgconfig
-PROGRAMS=test-lexing test-parsing obfuscate compile graph sparse test-linearize example test-unssa test-dissect
+PROGRAMS=test-lexing test-parsing obfuscate compile graph sparse test-linearize example \
+ test-unssa test-dissect ctags
INST_PROGRAMS=sparse cgcc
LIB_H= token.h parse.h lib.h symbol.h scope.h expression.h target.h \
@@ -93,6 +94,9 @@ test-unssa: test-unssa.o $(LIBS)
test-dissect: test-dissect.o $(LIBS)
$(CC) $(LDFLAGS) -o $@ $< $(LIBS)
+ctags: ctags.o $(LIBS)
+ $(CC) $(LDFLAGS) -o $@ $< $(LIBS)
+
$(LIB_FILE): $(LIB_OBJS)
$(AR) rcs $@ $(LIB_OBJS)
@@ -122,6 +126,7 @@ test-lexing.o: $(LIB_H)
test-parsing.o: $(LIB_H)
test-linearize.o: $(LIB_H)
test-dissect.o: $(LIB_H)
+ctags.o: $(LIB_H)
compile.o: $(LIB_H) compile.h
compile-i386.o: $(LIB_H) compile.h
tokenize.o: $(LIB_H)