aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosh Triplett <josh@freedesktop.org>2007-07-29 20:20:38 -0700
committerJosh Triplett <josh@freedesktop.org>2007-07-29 20:20:38 -0700
commit06bcf19cb8eb3cc3154ba6131477d742a9f0b4b6 (patch)
tree2c4cb951f3f6638ec263ababb19e833f20cac404 /Makefile
parenttokenize.c: Simplify drop_stream_eoln(). (diff)
downloadsparse-06bcf19cb8eb3cc3154ba6131477d742a9f0b4b6.tar.gz
sparse-06bcf19cb8eb3cc3154ba6131477d742a9f0b4b6.tar.bz2
sparse-06bcf19cb8eb3cc3154ba6131477d742a9f0b4b6.zip
Makefile: Use -O2 -finline-functions, not just -O
This makes debugging more difficult by default, but as usual, developers can change CFLAGS if they want to use a debugger; the default CFLAGS should cater to users. Signed-off-by: Josh Triplett <josh@freedesktop.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 478e151..6c327da 100644
--- a/Makefile
+++ b/Makefile
@@ -3,7 +3,7 @@ VERSION=0.3
OS=linux
CC=gcc
-CFLAGS=-O -g -Wall -Wwrite-strings -fpic
+CFLAGS=-O2 -finline-functions -g -Wall -Wwrite-strings -fpic
LDFLAGS=-g
AR=ar